The program may slow down or exit if it doesn't have enough Java memory to handle large projects or translation memories.  Then, please increase RAM memory that Java software assigns for CafeTran as follows:


  1. Make sure that you run CafeTran on the 64-bit version of Java if your system is 64-bit too. Check the Java version via the menu Help > About (the About panel). It should show Java HotSpot(TM) 64-bit Server VM.
  2. Go to Edit > Preferences > Memory tab and increase the default Java memory value (MB) to 2048 or 4096 or more. However, do not go over the total RAM memory available in your system. Leave some amount of RAM memory for the operating system and other programs that you use.
  3. On Linux operating system, edit Cafetran.sh file and increase the JAVA_MEMORY_MAX value (e.g 2048 or 4096 or more).
  4. Click OK and restart CafeTran.
  5. With large translation memories, perform Preliminary Memory Matching via the Translate menu.
  6. Increase automatic background saving intervals for Project segments, Memories and Glossaries in Edit > Preferences > Workflow tab > Autosave project/memory/glossary fields (from 20 to 50 segments/entries).


If you use the 32-bit version of Java, the software has the RAM limit of about 2 GB (2048 MB). You cannot install 64-bit Java on 32-bit Windows operating system.