Start a new topic

Wrong (and QA-undetected) tag position creates havoc in Word table

I'm translating a Word document containing several tables, where each segment (corresponding to a new table cell) starts with tag 1. But, in some cases CTE places this tag to the end of the segment instead, like this:

image


When running the QA tag check, no error is detected, but upon exporting the file I get this:

image


That is, the wrongly placed  tag 1 appends "Beni patrimoniali" to the previous cell (together with "Importi") instead in the correct position which is marked by the red arrow in the picture above.


This means that the QA Tag check function is not working properly, right?


Can this be fixed, please?



Thank you for the explanation, which I hope to remember for the next project.


Since there is no official operating manual, it would be nice if a sort of pop-up explanation were given for each menu setting, especially when they are likely to cause problems.

For CafeTran projects, this hiding boundary tags option should be always on. It helps CT to make sure they don't need take part in auto-assembling, which may lead a tag misplacement like in this case. For projects created in other tools, it might prove helpful to check their tags with this hiding option off.

Igor: I think in this specific case as in your screenshot, hiding the boundary tags (before translation is done) would help the program.


After ticking "Hiding the boundary tags" the issue has disappeared. Thank you.


But, how come that by simply *hiding* boundary tags CTE puts them in the correct place? Shouldn't their original position be maintained, especially if they could cause text in Word table cells and Excel cells to be misplaced?

 

 

> both "Hide segment boundary tags" and "Merge adjacent tags" are unchecked. 


I think in this specific case as in your screenshot, hiding the boundary tags (before translation is done) would help the program. It wouldn't need to handle the tags at all.

Hans: This is because, by default, CafeTran Espresso hides tags at the start and end of segments


Me: In the present case, I have many source segments with one tag only placed at the beginning, and both "Hide segment boundary tags" and "Merge adjacent tags" are unchecked.


This should mean that this only tag is marking the beginning of a table cell, and if misplaced it causes a cell to be merged with the previous one. You figure what mess it can create on a financial report if the tag position check is not implemented properly to cater for this kind of error too.


 

>I tried, and only "Trailing space check" seems to work


Ah, now I remember: in certain Trados projects (e.g. the ones created from Schema ST4 projects), you have to run both leading and trailing space checks. This is because, by default, CafeTran Espresso hides tags at the start and end of segments.


Actually, I have macro that adjusts leading and trailing spaces when moving to the next segment.


Long story short: it is good advice to always run all checks (except for the length checks, I guess).

I tried, and only "Trailing space check" seems to work, although (at least by its name) this is supposed to look for spaces only, not tags. Actually, this check would find both issues, although it's not always clear which one is which.


You are right about changing the name to "Tags at word boundary check", that is cloning the "Trailing space check" and name it "Tags at word boundary check" (to be run first).


Will Igor agree?

The second one should find these tag errors. Perhaps the name should be adapted to Tags at word boundary check?

I can see only two tag-related checks under QA: one is "Tags check", which I've used, and the other one is "At Tags spaces check", which doesn't seem related to my issue because there are no spaces at the beginning or the end of those sentences.


What am i missing, please?

Did you run both QA checks for tags?
Login to post a comment