Start a new topic

LO preview broken on macOS

The 11.2.1 update has the following changes:


- fixed an issue in the HTML-based preview.

- faster opening of LibreOffice when it is used for the source document preview.


HTML works

No launching of LO

No preview at all


macOS Big Sur


I can't confirm it. Restart LibreOffice and check the Preferences > Application connection in CafeTran.

Will do. Thanks.

Rebooted the iMac, checked the connection:

 

/Applications/LibreOffice.app/Contents/MacOS:/Applications/LibreOffice.app/Contents/Resources/java/libreoffice.jar:

 Launched LO. Created a new CafeTran Espresso project. A Preview folder is created:


image


Loaded the document in the preview folder via Resources > LO: nothing happened.


Am I doing something wrong here?

Go over the troubleshooting steps here. Check if you can open a LibreOffice document via the Resources menu.

You mean this? // Anyway, try to locate libreoffice.jar file, and then choose its top level folder called Libreoffice7.4 in Preferences > Application connection... > Class path... button.
Strange thing is that it used to work on my MacBook. Now it doesn’t anymore. In the past: https://youtu.be/PVqzHF6uxYo
> Check if you can open a LibreOffice document via the Resources menu. // Nope. Nor on the iMac with 11.2.1, nor on the MacBook with 11.2 (where it used to work).

Both LO preview and HTML preview are quite erratic here.


When I tried yesterday with a little file after upgrading to the latest build, they worked (I don't remember if it was a Japanese text). But today they don't work with a few Japanese paragraphs: at first, only paragraph numbers got highlighted (is it so because they are single byte?). At a second attempt neither those numbers got highlighted. Should I send the text for you to check?

 

When you choose a Project Template in the Dashboard, the connection to LibreOffice is lost. You need to restart CTE to reconnect. There will be a fix available soon.


>Should I send the text for you to check?


Sure, you can submit a ticket with .ctp package attached.


1 person likes this

I still can't get this to work.


I can see the message that LO is connected in the Dashboard.


First try:


1. Create a new project in CafeTran Espresso. 

2. Choose Open LO for preview. A dialogue box is opened and I can see a Preview folder being added

3. Select the document in the Preview folder: nothing happens.


Second try:


0. Open LO. The LO Dashboard appears.

1. Create a new project in CafeTran Espresso. 

2. Choose Open LO for preview. A dialogue box is opened and I can see a Preview folder being added

3. Select the document in the Preview folder: nothing happens.


Third try:


0. Open LO. The LO Dashboard appears. Launch Writer.

1. Create a new project in CafeTran Espresso. 

2. Choose Open LO for preview. A dialogue box is opened and I can see a Preview folder being added

3. Select the document in the Preview folder: nothing happens.


Fourth try:


1. Create a new project in CafeTran Espresso. 

2. Choose Open LO for preview. A dialogue box is opened and I can see a Preview folder being added

3. Select the source document: nothing happens.


Fifth try:


0. Open LO. The LO Dashboard appears.

1. Create a new project in CafeTran Espresso. 

2. Choose Open LO for preview. A dialogue box is opened and I can see a Preview folder being added

3. Select the source document: nothing happens.


Sixth try:


0. Open LO. The LO Dashboard appears. Launch Writer.

1. Create a new project in CafeTran Espresso. 

2. Choose Open LO for preview. A dialogue box is opened and I can see a Preview folder being added

3. Select the source document: nothing happens.

image

image


You don't need to select the source document from the preview folder. CafeTran opens it automatically.


1. Check if the "Highlight target segments" option in the Resources menu is unchecked if wish to mark the currently-translated source segments in LO.

2. Check if there are other LibreOffice source documents opened somewhere in your desktop(s). Close them all before opening the project. 

Restarted my iMac.

Created a new DOCX project.

Made sure that "Highlight target segments" wasn't ticked.

Chose Open LO Preview.

A dialogue box appears that invites me to open a document.

There is no LO process active:


image


Login to post a comment