Start a new topic

can't get new LibreOffice previewer to work (yet)

Hi Igor,

Very good news about the LibreOffice previewer, and I am really looking forward to testing it!

However, when I click:

Resources > Open LibreOffice for preview

a dialogue pops up saying:

"Install and choose LibreOffice in Preferences > Application connection."

However, I already installed it, and choose LibreOffice in Preferences > Application connection.

my class path =

C:\Program Files\LibreOffice\program\classes\libreoffice.jar;C:\Program Files\LibreOffice\program;

What am I doing wrong here?


> Can I just ignore it?

Yup, it can occur when you select LibreOffice first time, having the settings from the CTE previous version.

> IMO the use of a preview isn't something that should be set at the app level, but at the project level.

I just can't find any reason not to use it mostly. It doesn't take up any CafeTran's resources, nor it interferes in the translation process.

It sends data to PRC.

Do you mean the processor or something else?

It’s Saturday, so was just joking. People’s Rep of Chin.


Me: I want to be able to see at a glance what comes before and what follows the currently translated segment, or in what text block I'm currently in.
Igor: CafeTran's own project's grid does exactly what you say, doesn't it?

Of course I can see in the grid what comes first and what follows. (With patents, some segments are so long that at times in the grid you can see only two or three segments depending on the overall CTE layout.) But, particularly with no technical texts it may also be important (in Italian at least, in my opinion) to see what (separate) block of text the current segment belongs to exactly, for it might be needed to adjust the translation accordingly. (On the other hand, to this purpose the *real-time* target preview would be needed, which seems to be out of the question.)

Normally I keep the source document opened on a different workspace, but this involves going back and forth with additional clicks.

Igor: As I said in the announcement, with duplicate searched strings, LibreOffice search function selects the first one found. This is the current limitation.

Me: I'm sorry, but this is a strong limitation in my view. I tried with a technical document full of repetitions and the tracking highlighting keeps jumping back and you loose track of where you are in the document. I hope this can be fixed some way.


Do you think it's possible to fix the tracking function in the tabbed Html preview? Or, even better, adding the real-time target preview there?


Igor, thanks for the pointers.

In Regolith Linux (Ubuntu 20.04), LibreOffice is not installed in the /opt directory.

whereis libreoffice
libreoffice: /usr/bin/libreoffice /usr/lib/libreoffice /etc/libreoffice /usr/local/bin/libreoffice7.4 /usr/share/libreoffice /usr/share/man/man1/libreoffice.1.gz

As advised, I downloaded and installed the latest LibreOffice for Debian-based distros from the official LibreOffice website (not the Ubuntu repos) and installed the .deb files included in the archive according to the readme file. A new LibreOffice installation now exists:

whereis libreoffice7.4
libreoffice7: /usr/local/bin/libreoffice7.4

This is the default name and location, I was not asked to choose.

When I click on the Class path button, and select the /usr/local/bin directory, the path field is not populated. I can, however, paste the path manually.

It worked once right after installing and launching libreoffice7.4 and pasted /usr/local/bin/libreoffice7.4, but since then,I have been trying to replicate this, and I get the error message that I need to Install and choose LibreOffice in Preferences > Application connection.

Please note libreoffice7.4 in /usr/local/bin/libreoffice7.4 is the executable, not the directory. If I point to the directory /usr/local/bin, how CafeTran know which executable to use? For Linux, I guess it searches for libreoffice?

Can you provide an example (or possibly a video) of how to set this (and which directory is required) in Linux/Ubuntu?

Also, I suspect CafeTran cannot find the executable libreoffice7.4. Instead of setting the directory, can we get to select the executable?

I don't want to stop trying just yet, because this new feature is a very promising development.

When experienced users struggle with this, you know there is some room for improvement, at least in the instructions department.

I'm not sure what automation tool the developer used for controlling Writer from CafeTran Espresso. It must be one that is cross platform.

Reply: if you use MRI to have a look you'll see that each paragraph has its own identifying ID - local name/metadatareference/stringvalue
Perhaps you can use that?

Getting back on this topic:

> launch writer via: /Applications/

IK: A macro to launch the app? What's wrong with just launching it via Launchpad?

With this simple macro you can launch Writer directly without this stupid Gallery.


Today I gave another try with an Excel file: LO Calc opens normally, but there is not segment highlighting although the relevant function is selected in the Resource menu.

> Can you provide an example (or possibly a video) of how to set this (and which directory is required) in Linux/Ubuntu?

On my Ubuntu testing machine, I repeated the installation of the downloaded Linux .deb.tar.gz installer from LibreOffice site. After extracting it, I followed the installation instructions in the README file - Installation of LibreOffice on Debian/Ubuntu-based Linux systems section. This resulted in LO installation in the /opt directory. Anyway, try to locate libreoffice.jar file, and then choose its top level folder called Libreoffice7.4 in Preferences > Application connection... > Class path... button.

Thank you, Igor,

Mea culpa, I hadn't noticed that the installation had happened in the /opt directory, got confused with the output of the whereis command.

Your additional instructions, that the Path field needs to point to the directory containing the libreoffice.jar file helped me find it in /opt/libreoffice7.4/program/classes

After resetting the preferences, it seems to work. Thanks again!

On Ubuntu 20.04, after renaming the .java folder in my home directory (which in Linux stores some additional related settings) and resetting the preferences again, I was able to test the Libreoffice source and target preview features and the PDF file translation (ticket raised for some PDF still not working).

For target preview, exporting a new preview file and selecting it again through the CafeTran dialog makes opening the target text preview quicker.

Login to post a comment