CafeTran Espresso 11.2 - Éclair

CafeTran Espresso 11.2 -  Éclair version is available for download.

 

Important! Do not update before exporting your current projects. Please complete all your translation projects in your current CafeTran version before updating.

 

The update can be performed via Drag and Drop as follows:


1. Make sure your current CafeTran version is at least 10.7. It also should run on Java 11 or a higher version. Please check CafeTran and Java version in CafeTran's Help > About panel.


2. Download 20221121_update.zip file from here and place it on your desktop. Do not unzip or rename the file after downloading.


Note: On macOS system, Safari web browser may unzip the file automatically after downloading it. Before you download the update file, uncheck the following Safari option:


Safari > Preferences > General > Open "safe" files after downloading or use another web browser for the download.


3. Drag and Drop the downloaded 20221121_update.zip file anywhere in CafeTran's initial screen - the Dashboard.


Alternatively, you can install 20221121_update.zip file via the "Install Update" button in the Help > About panel instead of dragging and dropping.


What's new:


I am happy to announce CafeTran Espresso 11.2 Ekler update featuring much improved connection with the LibreOffice suite. Firstly, it enables the translation of multiple file types which LibreOffice supports, including the infamous PDF format. Furthermore, CafeTran can use LibreOffice for the real-time preview of the source document as well as the exported target language document during the review phase. The steps to connect CafeTran with LibreOffice are as follows:


1. Download and install the latest version of LibreOffice - Mac, Windows and Linux downloads are available. For Linux users, I recommend downloading it from LibreOffice site directly, rather than from your distro repositories.


2. Launch LibreOffice.


3. In CafeTran, go to Preferences > General tab and select LibreOffice in the Application connection field. CafeTran should detect LibreOffice installation directory and set the paths to LibreOffice in the Application connection panel.


After successful connection to LibreOffice, CafeTran opens a copy of the source language document for preview and highlights the currently translated segments.


If you wish to highlight target segments in the exported document:


1. Select the "Highlight target segments" option in the Resources menu.


2. Open the exported target language document via the menu Resources > Open LibreOffice document for preview... .


Currently, the preview function works with one caveat concerning duplicate segments. As CafeTran searches for the current segment in LibreOffice document, it can highlight only the first segment found.  


When CafeTran opens a PDF file (or other formats edited only by LibreOffice), it switches to the translation mode with the help of LibreOffice editor. Then, the export of the translation is directed to LibreOffice transferring target segments to LibreOffice editor.


Other new features:


1. New character-based filters for CJKV, Greek, Cyrillic and Latin languages - see the Filter > Characters menu.

2. Updated list of languages supported by Deepl.com MT.

3. Doubled the number of resources allowed to display in the Dashboard.


Enjoy,

Igor


6 people like this

The 11.2.1 update has the following changes:


- fixed an issue in the HTML-based preview.

- faster opening of LibreOffice when it is used for the source document preview.

- added the Occitan (oc) language.

Changes in CTE 11.2.2 update:


- fixed LibreOffice connection issue when selecting Project Templates in the Dashboard.

- switch to Unicode in glossary terms containing regular expressions with predefined characters.

- search options for glossaries are saved now.