Start a new topic

How to "simplify" a glossary

Hi all,
I wondered if there is a way to reduce the source text entries in my glossary, which I feel are quite redundant at the moment. I suppose there is a way to simplify things!

Let's say I want to add to my glossary a verb like "make a habit". So far I did something like this, i.e. adding all possible variants of the verb "to make"


Is there a way to insert just one term instead? I tried to have a look at the online resources, but I am still a bit puzzled - should I use an asterisk, for instance, inserting just "ma* a habit"? And in this case, will CT recognise automatically all the possible endings (make, makes, made, making)?

Thanks for your help! Any suggestion to simplify my glossary is more than welcome :)

Throwing used matches in a bin is a habitual preference. Will be matched too. To prevent this, use ma[eidgkns]+ a habit or even ma[a-z]+ a habit
You can assign [a-z]+ to a shortcut

Uh-oh, I am definitely lost here. Guess it's better for me to stick to things I actually understand, this is probably too advanced for me :)

Thank you Igor,

I tried to apply your suggestions to a new term in my glossary, just to try this function. In this case, I tried to add "fit into" with all its variants (fits into, fitting into, etc.) to the glossary and it appears like this:


I tried this alternative as well:


Despite being featured in the glossary, the term "fits into" appearing in my translation is not highlighted, ad I am not getting any suggestions in the matchboard. Do I have perhaps to configure some additional settings?

Thank you.


what do those xxxxxxx mean? Try to remove them.

I was just being lazy and I did not type the translation in Italian, that's it. However, even if I did,


the term is not highlighted in the source text:


I tried to save and reload the glossary before taking this screenshot. "Fit" is highlighted regularly, as it is featured in a separate entry, but "fit into" is not.



Have you tested it with other phrases or is it just the one that doesn't work? The first "fit into" expression (in your screenshot) will not work, so please remove it. The second one (|fi.+? into) should work provided that the white space between "fit" and "into" is the regular one.

Login to post a comment