Start a new topic

Translation memory and matchboard


When I started using CT, I created a single translation memory. The matchboard accurately proposed me segments with 100% match from previous jobs. For a few months now though, this doesn't happened. I created two mock files, saving version 1, added an extra sentence and saved it as version 2. Once having translated version 1 and added the segments to the memory, I went about with version 2 and none of the identical segments appeared.

Any insight on how to fix that would be greatly appreciated.

I am not sure what you mean by the mock files. In the first place, you might reset CafeTran's preferences to its default settings - the same when you started using CT. It can be done via Edit > Preferences > the Reset button. If it does not help, it means that something is not correct with your translation memory files (the mock files?)

What I meant by mock files is that I opened a Word document, wrote two sentences, saved it as version_1, added a sentence and saved it as version_2. I then opened version _1 as a new project, translated it, adding the segments to the memory and exported it. I opened version_2 as a new project. Before, matching segments from previous jobs used to appear on the matchboard (101% match or something alike), but now, despite being exactly the same file but with an extra sentence at the end, no match. I basically have to redo the whole translation, which is less than optimal and time consuming.

I've done the same procedure after having doing the reset as you suggested, with the same results, no match appears.

You don't say whether you share the same translation memory between those project. By default, CafeTran creates separate translation memories ProjectTMs for each project. They only work in the given project's context.  If you wish to have a translation memory for both project, you need to create it via the menu Memory > New memory... . Then, the newly created memory can be shared between the projects.

If you can't see the Memory menu, please activate it via the View > Show memory menu.

My bad. When I started using CT, I thought that I created a common, global memory, where all the segments were added. It appears on the Translation memory panel, and is always ticked before starting a job.

It remains that, despite never having created a translation memory for specific common jobs, there was a time when I could see entire segments previously translated in the matchboard. For instance, I had jobs were some sentences always occurred either dot for dot or with few words changed. The matchboard proposed me the 101% exact match, fully highlighted green segments or basically the very backbone of it.

But few months ago, that stopped. Interestingly enough, that was around the time when CT thought (wrongly) that my license had expired, I had to reload it couple of times.

Make sure that your global memory can be loaded in both projects. You should see its tab after opening the project. Then, check if it has any contents by right-clicking at that memory's pane/window and selecting the "Browse memory forward item" in the pop-up menu. You should see the number of segments this memory contains.

It's loading properly, but checking the number of segments reveals that it's basically empty. 210 segments for over 3 years of work. I was really under the impression that since Project memory and my "own_memory" where ticked in the TMX panel, CT would add the segments to the global TM as well as the own project TM.

So, follow-up idea: would creating a new Total recall memory with all the previous jobs work and how can I be sure that every new jobs segments get added to it?

Thank you for taking the time in helping me solving that.

You may have switched to the "Read only" option for you global TMX memory. Using Total Recall is a good idea. Please check the details here:  

Thank you very much, I'll do just as you suggested!

Login to post a comment