Start a new topic

ProjectTerms

Hi, I am new to CafeTran. I am trialling it with a view to upgrading to a full licence. However, I can’t get it to work. I really want it to work because I work on a Mac and I don’t really like the other Mac-based options. I have the following issues: 1. When I add a term from the source text to Project Terms (using the Add Term to Glossary button), it doesn’t show up under the ProjectTerms tab when I am still in the same segment or when I return to this segment. There is one word that is highlighted in beige in the source text, and this is the only word that appears under the ProjectTerms tab. I don’t know why this word is highlighted nor why it’s the only word that appears in ProjectTerms. 2. When I go to Glossary -> Reload glossary, the entire glossary (not just the terms included in the segment, but the entire glossary) will be shown under ProjectTerms. But I when move to a different segment, the glossary disappears again and I need to do Glossary - Reload glossary all over again (once again, the entire glossary). I need to keep doing this every time I move to a new segment. Otherwise, the ProjectTerms window is empty. 3. Sometimes a red dot appears under a segment number. It’s not a segment I’m working on. What is this red dot? Thank you.

I have figured out the issue. My source language is Korean, and Korean poses two problems: 1. it uses characters not letters; 2. the characters are joined together to create "words (a clump of characters, essentially)" which, in English (for example), would be the equivalent of joining multiple words together into a single word, e.g., "Thatis", "toschool", "onlyresults" and "doesn'tevenattempt". On the other hand, thousands of terms can consist of a single Korean character. "Cooked rice", "snow", "house", for example, all consist of a single Korean character. Therefore, in order to capture all the matching terms, I would need to select Prefix matching and set the Minimal prefix length to "1". However, this then creates the problem of capturing all the words consisting of two or more characters that start with one matching character. The first example that came up in my case was "하얼빈" and "하다". These two terms share the same first character, but in the former, this character is the first syllable of Harbin (a city in China) while in the latter, this character is the stem of the verb "to do". It's like matching "Harbin" with "happy" because they both start with "ha".

The best way to get around the issue would be to keep the Minimal prefix length to "1" and just ignore the bad matches, so it's not an insurmountable problem. I just thought it was worth flagging. Thank you for your help, Igor.

Your glossary terms may appear in various forms in the sentence. Then please enable Prefix matching option in Edit > Preferences > Glossary tab to increase the chances of their matching.

I've now found that sometimes a matched term appears in the ProjectTerms window (with the beige highlight in the source text) and sometimes it doesn't. There doesn't seem to be any pattern as to why a particular term sometimes shows up and sometimes doesn't. A term in the source text in segment 5, for example, will show up in the ProjectTerms window, but in the very next segment, this exact same terms will not show up.


I hope it's just that and not anything more problematic. I tried many times to attach a screenshot of the interface to my post, but whenever I do, the post won't go through. I did create a new project at the beginning, and when I reopen the CafeTran app, the project shows up next to the Open button. There is also a Project file on my computer containing all the files. I completed the project through to the end (It was a small demo project)  and exported it, so the Project file contains the exported bilingual file as well as the ProjectTerms.txt...

Probably, you haven't created a new project with the document for translation yet.  You may be editing the translation memory (a .tmx file) only.  You can attach the screenshot of the interface after loading the file to check it.

Also, now there is a “Creation Date” row with a time stamp under each segment on the left. This wasn’t there before. Just came up for the first time now. It seems that every time I open CafeTran, there is something different from the previous time.
I’ve an update. I closed the CafeTran app for a while and reopened it, and now, none of the matches are highlighted in beige. In every segment, the entire glossary shows up in the ProjectTerms window (not just the terms in the segment but the entire glossary).
1. I created it inside CafeTran. Yes, the language pairs are the same. 2. Yes, but several terms within the segment are in the glossary. Of these, only one of these is highlighted in beige and shows up in the ProjectTerms window. None of the other matches show up. However, when I open the Glossary though Edit Glossary, those terms that are not highlighted and not showing in the ProjectTerms window are in the Glossary. 3. Ah, thank you. Mystery solved.

Hello,


1.  Did you edit the ProjectTerms glossary in some external editor? Was it created in CafeTran? Is the language pair (see the green header after reloading) of the glossary the same as the project's language pair?

2.  When you move to the next/previous segment, the glossary shows only the glossary terms present in that segment (highlighted in beige) or nothing if CafeTran can't find such terms.

3. The red dot indicates that the segment has been edited in the current session.

Login to post a comment