Start a new topic

Cafetran on fire, my computer is burning


I've been using Cafetran on a 2015 MacBook air. Never had any problems.

I just decided to upgrade and I bought the last MacBook Pro (with the last version of Catalina 10.15.7).

I downloaded Cafetran 10.8.1 and Java 15 openJDK.

It works. But Cafetran is using like 120% of my processor (is it even possible?). The computer is hot as hell and the ventilator in Power Rangers mode. It's terrible.

I tried to change the appearance to metal (I read it here), I tried many other tips with no results.

I really don't know what to do anymore... any ideas?

Peace ✌️ 

Sounds horrible and makes one reluctant to buy a new Mac. Can this be a graphics issue?
Kill the Antivirus software?
As a temporary workaround: install VMware Fusion, Windows 10, run CTE there.

Do you know if it's possible to download an old version of Cafetran for Mac? Like Cafetran Akua (2018)? I've found old updates to download but not the dmg.


I don't think so.

Instead of virtualising Windows, you could also try to virtualise an older version of OS X, like HS:


However, I'm not sure what it means, when you find that CafeTran Espresso doesn't cause any heating problems in this OS X VM ...

It would be good to pinpoint the cause of the high CPU usage. Does it start right after CafeTran launching, or after your load you translation memories and other (web) resources? How large is your translation memory? Does it help if you open your project without any web resources activated (by unchecking them all in the Dashboard)? Maybe one of your web resources is causing it?

Pinpointing is exactly what has to be done.

Note, however, that on his old Mac, there weren't any problems. So chances are that some part of the new hardware is more critical/is causing the problems.

Virtualisation of OS X wil use a virtualised, generic graphics driver, I guess, if CafeTran Espresso runs flawless in this mac VM, the graphics driver/card could be the culprit.

Or am I at a wrong track here?

The new graphics card might be the issue in the context of a specific Java version not optimized/tuned yet for this specific card. There is a plan to let the user run (e.g for testing) CafeTran on the system installed Java instead of the embedded one.

It start right after CafeTran launching + I don't have any Translation Memories. I downloaded a brand new Cafetran. I only use MyMemory and Deepl as resources, and it doesn't help if I uncheck them.

I wanted to try an old version of cafetran without the embedded Java, but I didn't find any.

As soon as you notice the high CPU usage, please check Java memory value displayed in CafeTran's Help > About panel > Java memory size bar. If the used Java memory value approaches the maximum, increase the maximum default on Mac (2048) to 4096 in CafeTran's Preferences > Memory tab > Java memory field and restart. You can increase it to a higher value, but do not go over the total RAM memory in your system minus approx. 2-3 GB for the other vital resources that take RAM in your system.

Yes, I checked, but the used Java memory value is always between 400 and 600.

I did increase the maximal default to 4096 too.

Login to post a comment