Start a new topic

OpenJDK Platform binary crash

For a week or so I keep, randomly, getting CafeTran to lag in the middle of a project, then it freezes. After I try to click it I get: "OpenJDK Platform binary is not responding". Is my laptop at fault or is it a bug? Could you help, please? This is my 3rd time force closing CafeTran with the hope it will let me finish this project. And the deadlines are no joke


You said that 2 weeks ago. I tried everything. It didn't work !

Both other users and I (the developer) are doing their best to help you. Another approach might be as follows:


1. Reset the program via Edit > Preferences > the Reset button.

2. After restart, set Java memory value at 2048 again in Edit > Preferences > Memory tab > Java memory field.

3. You can try increasing Java memory value just a bit more (e.g. to 2500). However, bear in mind that with 4 GB of RAM in your laptop,  half of that may be already taken by the operating system itself and other applications and/or cloud services.


4 GB RAM might be too low to work comfortably nowadays. Consider adding more RAM, which is the cheapest and quickest way to improve computer responsiveness.


In the meantime, to keep using your big TMs with less memory consumption, I suggest you also set the Matching type to Fuzzy (instead of Fuzzy & Hits) in each TM options: https://github.com/idimitriadis0/TheCafeTranFiles/wiki/3-TM-options#tm-options


"Greedy exact matches" should be left enabled, as per default setting.


For TMs that you only use for reference (read-only mode), you can also set the Workflow integration to "Preliminary memory matching" instead of "Automatic". The processing occurs at the beginning, then the memory/resource footprint is much lesser as you go through your translation project.


Finally, if you use web resources within CafeTran, also be advised these do consume memory/computer resources in the same way as if you had them open in a browser. If you use such web resources, try querying them outside CafeTran, without their tabs open. Furthermore, try disabling "Simultaneous web search" in the Resources menu.

Login to post a comment