Start a new topic



I just downloaded and drag'n dropped the update file on my open Cafetran app, as usual. I closed CT but it won't reopen. I shows in the Finder bar (still on Mojave, here) but that's all, the program will not open. I restartet my iMac but still no joy. What should/could I do now?

I saved my butt by copying the CT installation from a backup to my current SSD. And again I dragged and dropped the Doughnut update onto the open CT, same result, CT will not open.

1 person likes this

Make sure that Safari (or you) did not change the name of the update file or unpack it automatically while downloading. It should be unchanged.

I'm not using Safari but Opera, the file name is the following:, and it has not been unpacked. Will try downloading the file with another browser

You can try updating via CafeTran's Help > About panel. Click the "Install update" button there and select the update file. You should see the message about successful installation.

Ok, downloaded the file with Firefox, dropped the file onto the open  (older) Cafetran window, same result, that is, no joy.

I also tried to install via the Help menu, same result, no joy.

I'd like to point out that in years and years of updating CT this never happened.

1 person likes this

Check if the previous updates work (e.g. Brownie) in your system. Maybe you skipped some important updates? Do you see the message about successful installation of the update?

This is the version I reverted back to.

Will try again to install via the Help menu and see if I get a Successful install message


After installing via Help this it what is says:


...and when I click on the Cafetran icon in the dock, nothing happens, Only "Cafetran" is showing in the Finder bar, the program does not start.

While I'm at it: Java Control Panel says: Your system has the recommended version of Java.

Java 8 Update 231

1 person likes this

Shouldn't the now built-il Java server be listed as the Java version instead of the Java installed on your system? I think it should read "[Java version, probably 12 or 13] OpenJDK 64-bit Server VM".

This was the major change that was introduced a year ago, maybe it now produces a fatal error at launch for you. Maybe an error log or starting CafeTran from the terminal (not sure how that works on a Mac, probably once in Show package contents) can reveal more details.

Personal suggestion: Since you have a backup, I suggest you rename the current .app, install the latest CafeTran package (not just update), then, if it works, copy any relevant data from the old and the new .app via Finder (Show package contents). Preferences should be kept, but you can also back them up for an easy restore. Of course, CafeTran should not be open during the process.


*data from the old and the new .app=data from the old TO the new .app

Hi Jean

I already considered this, but I’d rather await Igor’s advice.

In the meantime I reinstalled Brownie from my backup.

AAMOF I quoted the system's Java version, CT's Java version is in the screenshot here above.

I don't see why all at sudden I get this problem, my last update was to Brownie about a month ago and everything was fine and Brownie is running fine.

The screenshot shows you are using the system Java version, not the built-in Java version, that is for certain.

I thought this is not possible by default anymore, unless the previous internal executable (shown in the package contents) is used.

At any rate, I understand you preferring to wait Igor's advice at this point.

Login to post a comment