Start a new topic

Improve Machine Translation with auto-assembling not working

Hi all,


we are currently evaluating CafeTran as a possible daily driver for all our translation work. We found the results of the machine translation via MyMemory the best so far.


However, when we try to improve its translation results by our own glossary or fragments memory, it doesn't work most of the time.


How I understand your FAQs, all you need to do in order to enable this feature is to check: Improve Auto-assembling with Machine Translation in the settings:

https://cafetran.freshdesk.com/support/solutions/articles/6000160533-auto-assembling-with-machine-translation


In my settings menu I can only see: "Team auto-assembling with machine translation"

Is that the correct setting?


We have tried to get it to work by adding specific entries to our glossary, hoping that the MT results would be adjusted accordingly. However, that is not the case and I'm not certain what we are doing wrong.


Any help would be much appreciated.

Thanks in advance!



Did you give the glossary the priority 'High'?


Also: note that you have to experiment with the length of the glossary items that you want to be used by preference/to be injected in the MT suggestions.


What are your language directions?


I'm getting terrific results from DeepL, where my own, preferred glossary entries are injected in DeepL's suggestions.

Thanks for the reply,


I'll try setting the priority for the glossary to high and report back...


We are translating from English to German (EN => DE)

In that case, I'd absolutely encourage you to test DeepL. The underlaying EN > DE corpus is gigantic!


https://www.linguee.com/english-german/search?query=Werkzeugkühlung

Hi,


I think Team auto-assembling with machine translation has currently two modes. To test the mode you want, please make sure Automatic fragments adjustment is disabled both in Preferences > MT services and in Preferences > Auto-assembling.


Matched fragments and glossary entries are sent as masked items to the MT engine, so using a small set of resources (high priority fragments only) is recommended to avoid poor results.


I have not been able to make the other "smarter" mode (Automatic fragments adjustment) work consistently, but here is some more information:

https://cafetran.freshdesk.com/support/discussions/topics/6000058942


MyMemory: I think they have integrated DeepL results for some time, but now they have reverted to a combination of Google Translate and Microsoft Translator, plus you get matches from the public MyMemory TM.

@Jean: Thank you very much. 

It works now, but like your linked thread states, the automatic fragment adjustment does not work consistently for me either.

Login to post a comment