Start a new topic

Joining segments when working on MemoQ xliffs

Hello CafeTran users,

New to CT, did a first big job working on client-supplied MemoQ xliffs. 

All good except for one aspect: I had to join a few segments (e.g. 1st segment = "Maintenance" and 2nd segment = "Department": the French translation reverses the order of the words into "Département Maintenance", so I decided to join the segments).


In the CafeTran environment, both target segments appear filled in correctly, but client informs me that, on MemoQ, they see the first target segment but the second apparently is empty.


What is the best way of tackling such cases when working on mqxliffs? 


Not use the join function at all? Create an alternate translation? Tell the client that some segments may appear empty but it is not an factor as it should work when they create their final translated doc / xl /ppt anyway?

Thanks for your help.


Hello Idimitriadis,



As often, CafeTran knowledge comes from you.

Thanks for this answer, was not sure if there was a walkaround or not.

Will indeed submit a ticket, last one I introduced (tags from PPT files not visible on CT) was answered in no time at all and corrected promptly.

I agree that, until then, simply creating "non propagable" target segments is probably the way to go.

Have a great one and again, thank you for your answer. 

- Use this new feature with care making sure that boundary (opening and closing) tags between joined segments are in place.


- I suggest you open a support ticket. In the past I have informed the developer that the virtual merge feature results in empty target segments in  MemoQ files/packages, and the issue was addressed in build 2018091401, with the agency confirming there were no empty segments anymore.Maybe there is a regression, or the issue is more tricky than it seemed.


- If your client agrees to this, you can also export a Bilingual document (docx table), which will include any missing/empty target segment, which the client will have to use to complete the missing target segments in MemoQ before exporting the original documents. Project > Export and exchange > Export as bilingual document.


- Another option is to avoid using virtual merge altogether until the issue is resolved, and just use "virrtual joining" in your head or an external tool (if the two segments are long). I think virtual joining is mostly helpful in visualizing the change and helping you rearrange the syntax that span across two segments in an external tool, especially in case of incorrect segmentation. For segments with just one word each, I don't think it is that crucial to use it, however auto-propagation settings must be adjusted to avoid propagating wrong translations (at least, you need to check if the same segment needs to be translated in another way elsewhere).

Login to post a comment