Start a new topic

Propagation of segments that only differ in non-translatables

Has propagation of segments that only differ in non-translatables already been implemented? Does it work in CTE installations of other users?


image



image


If so, my issue is probably related to a particular settings problem that I'm having:


https://cafetran.freshdesk.com/support/discussions/topics/6000059045


That's one of my favorite features in memoQ ^^, you get lots of 100% matches, even wen it differs in numbers and/or punctuation.

I'm translating software strings and have to confirm 50 times segments that only differ in error number, slave number and master number.


This is no fun.

Have you tried using auto-propagation of numbers and/or non-translatables?


Alternatively, you might try using Autopilot (see Action > Autopilot) and possibly increase the Autopilot delay in Preferences > General tab if the default delay is too fast. You should notice the clock ON/OFF button in the target segment toolbar. You can pause the autopilot via Esc keyboard shortcut too.

Hi there!


All AP settings are selected:


image


Will try the Autopilot. Thanks!

Autopilot: a completely different approach for the task, but possibly an interesting feature!


From the announcement:

  • Autopilot. This may be a very handy feature during the Review or QA phase of translation. You can also use it when translating short, repetitive/similar phrases or numbers. It allows hands-free navigation with the set delay between the segments. The default delay of 2000 milliseconds (2 seconds) can be increased in Edit > Preferences > General tab. Activation/deactivation of the Autopilot is done via the Action menu. After that, you will notice the Autopilot button in the target segment editor. Click this button to turn on/off the Autopilot. Going to the next segment triggers off its functioning. To suspend it for a while (e.g for the correction of the current segment), press the Esc key or click the mouse on the target segment editor.

What does 'Fixed delay' in the settings mean?


image


Short segments, only differing in a trailing non-translatable, are inserted automatically nicely. Even though their FM percentage is below the set level.


I notice that all MT systems are triggered. Is this by design?

> What does 'Fixed delay' in the settings mean?

Here, the set delay is constant regardless of the segment length.


> I notice that all MT systems are triggered. Is this by design?


Sure, you might wish to navigate automatically via the MT results too.

> Autopilot: a completely different approach for the task, but possibly an interesting feature!


I hope it is. It lets you cruise through the segments hands-free grabbing the 'wheel' (to stop) only when necessary.

Very, very nice indeed.


Perhaps I'm nickpitting here, but to save some money (that can be invested in beer), perhaps it would be good to let MT sleep, while everything is inserted from the TM/AA.



That's really a personal choice which source of the translation result (e.g. Machine Translation, Translation Memory or Auto-assembling) to pick. You can make MT sleep via the right-click at the given MT pane (under the tab's title) and choosing "Stop automatic MT service".

What would be ideal is for MT to go to sleep on its own when there's a 100% match. You don't want to stop the service, you just want it to take a nap when it's not needed.


Also would be ideal for matches above a certain threshold to be inserted instead of MT, even when MT is set to automatically transfer to target segments. 


It'd be thirdly ideal if the threshold for this could be set by the user (so for anything above, say, 80% match, MT wouldn't sleep, but the 80% match would be inserted instead, with the MT presented underneath).


1 person likes this

> It'd be thirdly ideal if the threshold for this could be set by the user  (so for anything above, say, 80% match, MT wouldn't sleep, but the 80%  match would be inserted instead, with the MT presented underneath).


There could be a nice extension of the current MT auto-insert feature. CafeTran might respect the auto-insert thresholds for Memory and Auto-assembling set in Edit > Preferences > Memory tab and auto-insert the Machine Translation results only if those thresholds are not reached.  Fingers crossed to make it for the next update.


1 person likes this
Login to post a comment