Start a new topic

Question to those who translate Studio projects

This has been puzzling me for ages:


Even with the setting Skip EMs ticked, CafeTran Espresso 10 Croissant stops et every EM. That is: it is inserted in the target editor box, but I have to choose Go to next.


When I use Translate > Insert all EMs, all these EMs are inserted.


Why aren't these EMs inserted on the fly and skipped automatically, since that is what the Skip setting demands ...


I installed CafeTran Espresso 10 Croissant in a Windows VM and loaded the same Studio project, with the same TM that I was building on the fly, using CafeTran Espresso's default settings.


All Exact Matches are propagated correctly.


Big Question: Which settings in my Mac version of CafeTran Espresso 10 Croissant is hindering CafeTran to insert all EM's correctly? Where should I start?

I reset my Preferences in the Mac version of CafeTran Espresso 10 Croissant.


EMs still aren't inserted via auto-propagation.


How come? This cannot be Mac-specific, can it?

When there are 2 EMs, one 'exact' and one with different source (or is it target), these are inserted while the segment passes by.

There is obviously one or more settings on my Mac preventing automatic insertion and skipping of EMs in Studio projects. But which one?


BTW: My test project with the fresh CafeTran Espresso 10 Croissant for Windows didn't have a big glossary attached. Can the glossary be the culprit? Auto-assembling?

So, how should I proceed? Remove CafeTran Espresso 10 Croissant completely from my test Mac? And also the .plist settings file?

If I understand correctly what you wish to achieve:


1. First, perform Translate > Insert all exact matches.

2. Then you should be able to use that skipping feature activated in Action > Skip menu.

Sorry, Igor, but I'm referring to something else: EMs that are created during the session, won't be inserted automatically later that session.


On a clean CafeTran Espresso 10 Croissant under Windows this works allright, on my system, I have to use the procedure you just described. This is a little cumbersome, if I have to run that command every n segments.

Maybe you just need to activate skipping (the menu Action > Skip) Auto-assembling matches (if your glossary is involved) and setting high threshold (e.g. 100%) for those AA matches in Preferences > Memory > Auto-assembling insert threshold. Note that if there is an Exact Match, the auto-assembling algorithm picks it for auto-insertion.

I'll try your suggestion, with the new Studio project where my problem occurs. Thank you!

Login to post a comment