Start a new topic

Spellchecker marks all words mispelled

I've installed the Italian language pack in Linux following the link provided by Preferences > Spellchecker, the project is set to the correct language pair (Italian as a target) and Hunspell is selected in Preferences > General. The spellchecker technically works, but marks all words as mispelled.


Obviously there is something wrong, but what?


Many thanks for any advise.


Do you see two files named as: it-IT.aff and it-IT.dic in cafetran/resources/spellchecker ?


Which dictionary have you downloaded?


Try installing this one:

https://extensions.libreoffice.org/extensions/italian-dictionary-thesaurus-hyphenation-patterns


Not too recent (2915), but it should work. I don't know how to find the latest Hunspell spell checker dictionary for Italian.


Installation instructions:

https://cafetran.freshdesk.com/support/solutions/articles/6000110210-installing-a-spell-checking-dictionary


If you have LIbreOffice installed, you can also try setting the spell checker to :


Edit > Preferences > General > Spell checker = OpenOffice/LibreOffice. This will use the LibreOffice spellchecker.


Of course, make sure "hunspell-it" (or at least "myspell-it") is installed.

Hello Jean,


Cafetran/resources/spellchecker contains both the it-IT.aff and it-IT.dic files. They work on Windows but not in Linux (mine, at least). But the LibreOffice's spellchecker works. Thanks for the download link!

Login to post a comment