Start a new topic

Installing Cafetran on MX Linux (Debian)

First, I'm a Linux absolute beginner. I have been running MX Linux (Debian-based) for a couple of weeks now and after setting everything to my liking I decided to install Cafetran on it, but with no success. 

I've created a "Programs" folder in my Home directory and extracted Cafetran in there, but the only file that can be set as excecutable is "Cafetran" (no extension), which when clicked just opens a short script file. If I click on "Cafetran.jar", the End User License Agreement opens but even after clicking on the End User License Agreement nothing happens.

No doubut I am missing something important, but I don't know what. Any help, please?


Also, there are at least five instances of Java in the RAM (for a total of some 600MB), probably because I tried to launch Cafetran at least five times.

You can either force quit those Java instances, or simply restart the computer.

- Ctrl+I or right-click > Properties on the "Cafetran" file. In Permissions, check that the file is executable.

- What is your File manager? If it's Files (Nautilus), open its Preferences > Behavior and under Executable Text Files, check that when you double-click such a file, it is either set to Run them or Ask each time, not Display them. Then, you should be able to run the CafeTran executable by double-clicking it.

- You can create a .desktop file. for easier launch (you will be able to launch it via the menu, the dock, etc., as with other applications). For example:

Here's the icon that I use:

Thank you Jean, your suggestion to create a desktop file and launch CTE from there via the context menu was right spot on. Then, I was also able to achieve the same result by pinning the "Cafetran" file to a panel (dock). Perfect! Finally, I also found the way to use the native CTE icon, and now I'm ready to prepare CTE to work on Linux too.

Many thanks again for your help.


One more question, perhaps for Igor: Can the Preferences file exported from Windows be imported as it is into Linux?

You can try such a cross-system Preferences Export/Import. In case of any issues with the import, just reset the Preferences via the Reset button.

I'm trying another attempt with Linux, which I had abandoned some years ago after a disastrous MX Linux upgrade.

Now I'm on Linux Mint XFCE. CTE is in its own folder in the user directory, but I'm unable to launch it. First I've tried Cafetran (which opens a small script and that's it), and then Cafetran.jar, which is enabled to run as a program, but after accepting the license file nothing happens.

Any help, please?

Please make sure that Cafetran launching script (called Cafetran) is set executable so it does not open (e.g in an editor) but run. Don't launch it via the Cafetran.jar file.

It is also a good idea on Linux with less popular desktop environments to install a modern Java from the given Linux distro's repositories. CafeTran will not use that Java, but installing it should also link and download all the dependencies/libraries needed to run Java programs.

The Cafetran launching script (Cafetran) is already set to executable, but it keeps opening in the editor even after installing Java from the repository ("default-jdk" was called). Neither directly from the terminal I can launch it.

Linux Mint XFCE is quite a popular distro, and I was using the XFCE DE with MX Linux too some years ago.

Do you have other ideas?

The Java package I've downloaded (called "default-jar" in the repository) is the openjdk-11. Perhaps a different one should be installed?

Thanks Igor! Indeed, it was a Thunar issue and now I can normally open CTE by clicking on the Cafetran script. Perhaps these tips should be referenced somewhere for other Linux users?

I am on MX Linux and I have never had a problem with the launch script. I just press Alt-F2, type Cafetran, and press Enter.

Login to post a comment