Start a new topic

Installing Cafetran on MX Linux (Debian)

First, I'm a Linux absolute beginner. I have been running MX Linux (Debian-based) for a couple of weeks now and after setting everything to my liking I decided to install Cafetran on it, but with no success. 


I've created a "Programs" folder in my Home directory and extracted Cafetran in there, but the only file that can be set as excecutable is "Cafetran" (no extension), which when clicked just opens a short script file. If I click on "Cafetran.jar", the End User License Agreement opens but even after clicking on the End User License Agreement nothing happens.


No doubut I am missing something important, but I don't know what. Any help, please?


Thanks


Also, there are at least five instances of Java in the RAM (for a total of some 600MB), probably because I tried to launch Cafetran at least five times.

You can either force quit those Java instances, or simply restart the computer.


- Ctrl+I or right-click > Properties on the "Cafetran" file. In Permissions, check that the file is executable.


- What is your File manager? If it's Files (Nautilus), open its Preferences > Behavior and under Executable Text Files, check that when you double-click such a file, it is either set to Run them or Ask each time, not Display them. Then, you should be able to run the CafeTran executable by double-clicking it.


- You can create a .desktop file. for easier launch (you will be able to launch it via the menu, the dock, etc., as with other applications). For example: https://www.maketecheasier.com/create-desktop-file-linux/

Here's the icon that I use: https://i.imgur.com/lZw4j0V.png

Thank you Jean, your suggestion to create a desktop file and launch CTE from there via the context menu was right spot on. Then, I was also able to achieve the same result by pinning the "Cafetran" file to a panel (dock). Perfect! Finally, I also found the way to use the native CTE icon, and now I'm ready to prepare CTE to work on Linux too.


Many thanks again for your help.


Mario

One more question, perhaps for Igor: Can the Preferences file exported from Windows be imported as it is into Linux?

You can try such a cross-system Preferences Export/Import. In case of any issues with the import, just reset the Preferences via the Reset button.

Login to post a comment