Start a new topic

Series of noob questions: ctrl+z, increasing font size, disabling splitting into segments

Being, as the marketing people say, "really excited" about how fast and smooth the CafeTran trial works with files, I have to ask you several basic questions about the interface I don't really get, having moved from years of Trados'ing. Hope you forgive me for creating a cumulative thread with them.

1. Is there a way to make the translation grid organized Trados style, with original text on the left and target one on the right, without the window beneath?
2. Why does "ctrl+z" not work for reversing changes? Is there a way to make it work?
3. How do I increase the text size of the upper translation window (not the one I'm typing in)?
4. Why does the program split documents into some sort of parts ("segments"?) that you need to change between? Is there a way to disable this?

Will really appreciate your responses to the above questions, and to any questions that will likely come up soon. If this thing works as promised, I'm dropping 200 euros tomorrow without a moment of hesitation.

1. View > Segment editors > Horizontal segment editors (tick)

2. Not sure. You can try the Undo, Redo buttons present in the source segment editor.

3. Which one, do you mean the Grid? View > Font > Project, memory and resources. [Btw, CafeTran offers many Layout options. Check out View > Window layout.]

4. I'm not sure I have understood the question. I'm assuming you are translating a multiple document project. In this case, CafeTran lets you translate each document separately, or virtually glue the files together (I think like QuickMerge, in SDL Trados). The glue mode is an excellent mode to use, as auto-propagation works across files. You can glue or unglue documents together, and navigate between documents by pressing the open book (document) icon in the Grid, the Project menu > Documents, or the shortcut (Ctrl+D).

In the glue mode, when you reach the end of the file and the beginning of the next one, CafeTran displays a separation, to make it clear that this is a separate document. This can't be disabled, you can only choose between glueing or unglueing.


---


The official knowledge base is here: https://cafetran.freshdesk.com/support/solutions


You will also find links to some Reference documents I have compiled: https://cafetran.freshdesk.com/support/solutions/articles/6000186313-reference-documents


I suggest you take a look at one that is targeted at new users: "Getting comfortable (for beginners)".


* auto-propagation, but also find and replace work across files in the glue mode.

Undo/Redo only works for edit actions in the current target segment.


You can't undo edit actions after moving to another segment.

1. No, I'd like to throw the "segment editor" thing away completely - what does one need it for? It's a waste of screen space. I'd just like to type into the Grid (or the window displaying all the [presently uneditable] text)

2. Ok, ctrl+z works, it didn't the last time - don't know why

3. Done, thanks

4. I mean the function behind the arrows next to the progress bars and the Export button. They are used to switch between some sort of "segments". Why can't I just normally scroll through the entire document to begin with?


Another question: can you make it so that segments are switched up and down with up/down arrows, instead of alt+up/down? Just making sure before I jump into keyboard shortcuts.

1. Try View > Windows Layout >  Layout 6 compact.

4. Those are paging arrows with each project page set at 50 segments by default. You can increase the size of the project page in Edit > Preferences > General tab > Project page size. However,  it is not recommended to increase it too much as it may bring about some slow-down while navigating between segments.

1. The segment editors and the Grid are two separate interface elements, I'm afraid. However, the Layouts 5 and 6 can be set up in a way that makes them seem integrated. I suggest you give these two a try.


Other settings that might play a role in these layouts:

- View > Fonts > Current source segment/Current target segment, to adjust the font size to the segment editors.

View > Segment editors > Horizontal (or vertical) segment editors

- View > Tabs > bottom (or top) placement

- Adjust the segment editors size by dragging the top/bottom/middle separator. [I currently reported an issue with this feature for these Layouts]

- Hide/Show the segment editors buttons to gain screen space (Ctrl+Shift+H)


4. Ah, I see. You can define the numbers of segments that are shown per "Page" in Edit > Preferences > General > Project page size.

I don't know the reasoning for dividing a project into "pages" which can be navigated with the arrow buttons. This will have to be answered by the developer, but using fewer TUs per page is easier on RAM usage.


That said, you can jump to a specific segment by just typing its number in the Quick Search Bar (https://github.com/idimitriadis0/TheCafeTranFiles/wiki/2-Menu-and-Interface#quick-search-bar), if "Segment numbers" is enabled in the search settings (Ctlr+F).


--


In general, while some choices may seem atypical when compared to other tools, CTE does not seek to replicate or imitate other CATs, and it can provide a customizable and productive/responsive interface. One needs to spend some time to get to know the software and its options, and set it up to their liking.  


---


To Move to the previous or the next segment without committing it to the TM, the default shortcut is Alt+Left/Right. While you can customize the keyboard shortcuts, I don't think the up/down arrows will work without a modifier.


Sorry Igor, just saw your answer after publishing mine.

That's fine. Your answers are often better than mine. :)


1 person likes this

Thanks for all the answers.


Tried to do some tweaking, but can't seem to get the interface to a state in which it doesn't infuriate me with pointless screen estate waste on my 13" Surface... Bit of a shame TBH, but I'll try to live with it for now.

Here is an example of the Window layout 6 (15,6 screen,1920x1080). I don't know it that works on a smaller screen, although I the Surface should have a higher resolution.


Do you see the segment editors in the middle of the Grid? This layout integrates the editors (placed side-by-side, by default) and the grid, for a convenient, more compact layout, with the Matchboard always visible on the right. The segment editors are fixed in the middle of the grid, and the part of the grid that is meant to display the following segments is combined with the tabbed pane, with bottom tabs placement enabled (on the screenshot, I've used top placement instead).


- Full Screen mode enabled (F11)

- Hidden segment editor buttons (Ctrl+Shift+H)

- Optional: you may prefer the tabs to be placed in the bottom, instead of below the segment editors. In that case: View > Tabs > Bottom tabs placement.

- Optional: you can also toggle the visibility of the Quick Search Bar (Ctlr+Shift+F), it is displayed here.

- Optional: you can Join an often-used resource to the Matchboard on the right, to take advantage of vertical space. To do this, hover the mouse to the title "Matchboard", and click on the red cross.Then right-click on the Matchboard tab, and select Join tabs > the tab you want to want to use. Before that, disable the option Vertical tabs divider. Once joined, right-click on the tab > Dock tab to window vertically - right.

- Tip: There are keyboard shortcuts for quickly shifting to the next or previous tab, and tabs can be rearranged by drag and drop.




Ah, ok! I tried playing around with Layout 6 but couldn't understand the idea behind three different text windows in vertical arrangement, especially that on my screen there are two scroll bars displaying (see the screenshot below). To add to the confusion, the upper window went completely white at some point, and would only display segments again after clicking the lower window.



image


Either way, that looks much more tolerable now indeed, thanks a lot.


Q1: Igor, could you please confirm that there is no way to set segment up/down navigation with up/down arrows only?


Q2: I'm being a bit of a lazy bone, but what is the shortcut for copying source to target?


Q3: After hitting ctrl+shift+PgDn the entire text after the cursor is selected except for the last character. Why is that? Also, is it possible to change the shortcut to ctrl+down arrow, like in Trados?


Q4: What is the shortcut (if any - hopefully there is some) for deleting all text after the cursor? In Trados that would be ctrl+d and is a thing I use at least million times a day.

Window Layout 6 is a little more complex in that the top portion of the Grid stays always visible, and the bottom one is and behaves as a tab within the Tabbed panel. It takes a little getting used to, but it has grown to be my favorite Layout, so far.


Q2: Translate > Transfer source to target (Alt+I, by default). This works for the whole segment or for the selected text in the source text, which is inserted at the location of the cursor in the target segment.


Q3: Don't know. I use Shift+PgD to achieve that (I'm on Linux, though).


Q4: Delete to the end of segment: Ctrl+Shift+D (customizable)


You can review/customize keyboard shortcuts in Edit > Preferences > Keyboard shortcuts


If anything isn't self-explanatory, they are described here:

https://github.com/idimitriadis0/TheCafeTranFiles/wiki/1-Preferences#keyboard-shortcuts

> up/down arrows only


Up and down arrows are used to navigate through the text in the current segment just like in every text editor.

This post raises an interesting question: why do we need the grid and the segment editors? Why not integrate the two and let the user click around between segments and scroll at will as ekhangel suggests? It does seem like a waste of screenspace.

I can see that this would require quite a bit of recoding vis-a-vis filters and searches, etc. but wouldn't that be a great interface?


Login to post a comment