Start a new topic

CafeTran won't run without additional Java

When updating Java via the popup, it has the issue that the old Java is removed, but the new one is not installed.


However, after removing the old Java installation, CafeTran won't run and asks for a Java environment.

  • How can this be?
  • Which Java version to use? JDK does not help, and Java.com recommends "Java 8" – really? Wasn't there Java 9, 10 and 11 already?


Starting from CTE 10, the new installation includes the latest Java.  If you updated from the previous version, without reinstalling, CT continues to use Java installed in your system. If you uninstall it, the program won't run.  

Given you have reported several Java-related issues lately, I reckon your CafeTran installation has some issue, maybe due to the manual transition to the integrated Java version.


I suggest you backup the old app and migrate to a new one (same location), only restoring the contained user data.


I had to do this myself on Linux, my update instructions were propably missing something.

Did this pop up come while using CafeTran Espresso 10 Croissant? In other words: was it the embedded Java that required you to update?

Login to post a comment