Start a new topic

CTE very slow with a Japanese file

Since a week I've been translating a series of Japanese files which are slowing down CTE considerably. It never happened before. Each file contains approximately 8,000 characters, of which 4,000 are hidden. They are all docx files and are arranged in 2-column tables.


The problem is, at each operation CTE stalls for 3-5 seconds, and since translation units are many (they are all short sentences) I end up wasting much time on this job.


My Java setting is 4,000 MB, if this helps. What could the culprit be? Any suggestion please?


Do you translate all those files as one project  or is each file a separate project? Do you use the last CafeTran update with the Asian ideograms count in Project statistics? If you do, try turning off the Automatic update of project statistics in the Project > Statistics menu. Also, check external factors such other programs running and taking processor's power.

There are many details that might be the culprit. Two possibilities:

  • 4 GB RAM is the basic setting. This should and could be enough (with an empty TM), but try to increase it, if possible
  • For big TMs and not optimized Total Recall TMs (decrease "Recall in context") this can be too small, not to forget huge TBs. Any more info on this?
Maybe we get a kind of caching one day. 

> Maybe we get a kind of caching one day. 


You already have it in the form of Preliminary matching. Please see it in the Translate menu.

To Igor:


  1. I am using one file per project.
  2. I am using the latest build, and even after switching Automatic update off nothing changes
  3. My CPU real-time monitor is almost flat at 1-2%
To Tre:
  1. 4080 MB Java is my normal settings and it never gave me problems even with large TMs and Total Recall. In this case I am not using Total Recall and the only TM is rather small. The glossary is approximately 16,000 entries, but again it never gave me problems.

To be more precise, the CPU monitor stays to almost zero while doing nothing, but it jumps to some 15-20% peaks at each CTE operation (mouse click).

You can check the actual Java memory usage in CafeTran's Help > About panel. If it is close to maximum, you may need to increase it in Preferences. If it doesn't help, you can create a support ticket attaching a .ctp package created via Project > Export and exchange > To Package... .

Memory used: 380 out of 1600 (but in Preferences is set to 4096). Later I will open the ticket.


Thank you

Try changing slightly the Java memory value in Preferences and restart. Then, check it again in Help > About panel.

Login to post a comment