Start a new topic

Automatically adding a space upon export when translating with Japanese as source

In the Japanese language there are no spaces between sentences separated by full stops, colons and semicolons, Therefore they have to be inserted manually after export, or CTE gracefully does it automatically for us.


I don't seem to have found a way to tell CTE to do so. Therefore, if I'm correct, can CTE be implemented with such function, possibly as an option?


Thank you


I don't know if this request will be taken into consideration. I hope so, of course. 


But if yes, I believe it would be preferable to give the user the option to automatically add a space upon Alt+End-ing, because there are cases when the user prefers to do it manually (for instance when the Japanese source text includes strings that do not allow a space after the full stop).

IgorCafeTran adds the space automatically if both Japanese segment ends with Japanese full stop and your target language segment ends with full stop.

 


But when one splits the Japanese source segment, in two for example, the first one in the targhet is exported without space after the full stop.

Would it be possible to "always" have CTE automatically add a space after full stop, colon, semicolon, question mark and exclamation mark in the target segment? Or at least to provide an option to do this upon export?

The fact is, we don't always have the means to check the exported file before delivery.




CafeTran adds the space automatically if both Japanese segment ends with Japanese full stop and your target language segment ends with full stop.

Sorry, but it's not so, at least here. It happened again yesterday with both source and target ending with a full stop. 

You can submit a support ticket with your .ctp package (exported via Project > Export and exchange > To package), and please indicate the number of the segment which ends with the full stops in source and target.

Login to post a comment