Start a new topic

Adding resources to Total Recall

Hi, I am a newbie to CafeTran (but not to CAT tools). I am trying to re-use some of my TMs in CafeTran, but I must be doing something wrong, or else my CT installation is screwed up:

- I have exported my TMs to TMX.

- In CT's Dashboard, in the Total Recall pane, I click on Import TMX.

- I select my TMX file, click Open.

- Nothing happens (not even an error message). The Total Recall pane stays blank.

I thought that maybe I should create a new table before trying to import a TMX. I click on New (New memory table), but nothing happens (not even an error message).

I thought that maybe my TMX is too large (some 400 MB), so I tried to import a smaller one (300 KB). No luck either.

I have also tried to increase the Java memory size from the default 1024 MB to 4096 MB, but the setting does not stick after restarting CafeTrans.

Any clues?

Thanks in advance.


Hello Alessandra,

I confirm you have to create a Total Recall table (in the appropriate language pair) before importing TMs to Total Recall -

After that, when you press Import TMX, and select a TMX file to import, you should have an import dialog.

I understand that nothing happens when you try to create a new Total Recall table.

Can you check the database settings in Preferences? From the Dashboard, Preferences can be accessed via the Dashboard menu button next to the New button.

 In the General pane, what is the choice under Database connection? SQLite is the default and, I think, recommended option for standard use.

In this dropdown menu, you might want to create a New database since the current one does not seem to work..

Beforehand, copy the information found when you press the Database connection button with SQLite selected.

Then, paste that information in the same fields of the New database dialog, only change the last bit in the Connection URL, from SQLiteMemoryBase.db to something slightly different, such as SQLiteMemoryBase-new.db

Then provide a name for the .res database settings file (again, you can choose something such as SQLite-new).

Select the newly created database in the Database connection setting, close the Preferences, create a new TR table and try importing your TMX once again.


Also, the TMX is definitely not too large, although it may take some time to be imported, depending on your computer specs.

However, you could try importing a smaller one for your first test. You can always create a new Table and delete the old one if needed.

Re: the RAM setting that does not stick upon restart, what is your operating system? Since CafeTran is cross-platform, instructions may vary depending on the OS-type.

Hi Jean, thanks a lot for your help.
I have followed the steps above, but, when I tried to save the new database, I saw that I was not allowed to save it in CT's default folder for databases. So I went to CT's installation folder and changed user permissions (I have given all permissions to all users). After doing that, I could create a table and import my TMX.
The Java memory setting still does not stick, though. My OS is MS Windows 10.


Nice! I'm glad you have solved the database issue.

For the Java memory setting, I think Igor (the developer) should chime in, as I have noticed the same behavior in my GNU/Linux installation since the Java runtime server has been integrated to CafeTran (the program relied on external Java before). The setting does not stick when I define it in Preferences > Memory.

In GNU/Linux, CafeTran at least offers an executable script which allows to set the Java initial and maximum memory: 

# Java initial memory:


# Java maximum memory.


However, I can't find anything similar in Windows.

Also, the installation instructions found in seem outdated, at least for GNU/Linux.


1 person likes this

> The Java memory setting still does not stick

That's probably the file permission issue too. On Windows OS, Java memory settings are stored inside CafeTran main installation folder (Cafetran.bat file). If files in these folder can't be written to, the settings can't be updated either. 

> The setting does not stick when I define it in Preferences > Memory

On Linux you may be using the previous version executable file, which is still fine. The updated executable script is included with recent CT installations. 

I am using the updated executable script. OK, I will try again later on, and if the memory does not stick across restarts when setting in Preferences > Memory, I'll just open a support ticket since I understand this method is expected to work.

Login to post a comment