Start a new topic

Different Linux graphical environment and Cafetran

There are two graphical environment in ubuntu: xorg (old one) and wayland (new one). On my computer, Cafetran runs on xorg, but not on wayland. Cafetran is not supporting wayland? 


I'm now having problems installing a spelling dictionary, plus CT keeps switching me back to the Free version with the message that my SystemID has changed (which it hasn't). Importing the licence file again works fine each time.

I'm not really sure how I've got to this point, but I'll play around some more this evening.

Good to hear!


Yes, the SystemID changes if you change the folder path. Maybe that's what happened.


You may try using the same folder path as before and reimporting your previous licence.


Otherwise, obviously, a new one will do as well :-)

Thanks Jean! I've got CT running with your executable.


My SystemID has changed apparently though, so the licence file isn't accepted anymore - I've submitted a ticket.

With the new version, you should run the "Cafetran" executable which calls the integrated Java.


Maybe your current installation does not have the necessary java files, but even if it does, I have noticed that CafeTran does not run with the external Oracle Java or OpenJDK version. At least this is what happens with external versions 11 and 12. Oracle Java 8 works, but it is better to do a fresh install and just run the new executable, which uses an integrated OpenJDK 12 version.


If you are using Wayland, you can then try running the file I have shared once you copy it in the cafetran directory. 

I should probably just do a fresh install...

Thanks Jean.


When I run cafetran from the command line, all I then get is this:


image


Assuming you have the latest CafeTran Espresso version installed (if not, test this on a fresh install, this executable is meant for the integrated CT Java), here's the modified executable I've successfully used in Wayland (I'm now back to X11, as I had issues setting a custom resolution for one of my external displays).


Copy the executable to the cafetran folder.


Also note the JAVA_MEMORY_MAX setting has been upped somewhat.

Hi Jean!

How do you do this exactly? I can't get Cafetran to run on Bionic at the moment...

Until this is fixed, adding -Djdk.gtk.version=2 to the java arguments in the Cafetran executable makes it work under Wayland.

Yes, you need to run CafeTran on Xorg for now as currently Java (the programming language CafeTran has been written in) does not run on Wayland (https://bugs.openjdk.java.net/browse/JDK-8210411). It may be fixed in the next Java 12. 


1 person likes this
Login to post a comment