Start a new topic

Deleting segment from TMs a bit confusing

Please explain if I am doing it right: When I want to remove a segment from a TM using the "Browse memory" command—let's say I want to delete segment 1—it remains visible in the TM pane. Then, if during the same session I want to remove segment 2, in the pop-up window segment 3 is shown, not segment 2.


Perhaps, although still visible in the pane after deletion, segment 1 doesn't actually exist anymore in the TM; so when right after that segment 2 is selected, in reality it's not segment 2 but segment 3, right? Is this the intened behaviour?




Let me put it in another way: By mistake, yesterday I sent all project segments to a "fragment"-specialized TM. Fortunately, these segments are not many so they can be removed manually quite easily. But, what is the best way to remove memory segments selectively?


For example, even after clicking segment numbers and hitting Delete (in the TM opened in the translation grid), they seem to remain in the TM).


OK, I found my way through this issue and could edit my TM as described in an Igor's post.


Now, the fact remains that when clicking on Delete in the tabbed TM pane, TM segments are not actually deleted and the problem described in the first message above occurs. 

If you browse the memory Forward or Backward, are the deleted TM segments still present? They might still appear unless the view is refreshed. 

Jean: ...are the deleted TM segments still present? They might still appear unless the view is refreshed.


I did another test, just to be sure. 


After browsing a tabbed TM (ProjectTM), I hit Delete on segment 1: no visible results, segment 1 was still there. Then I clicked on segment 2, but in the pop-up window segment 3 appeared instead. I closed CT, and upon reopening it segment 1 was still there. I confirmed this also by opening ProjectTM with Notepad++. Therefore, in my case at least, the Delete button doesn't eliminate existing memory segments.

> I closed CT, and upon reopening it segment 1 was still there.


You may not have saved the memory manually after the deletion. In the next update, CTE will detect the change and save the TM automatically at exit.

I didn't know that saving the TM manually was necessary. One more thing: would it be possible to add a sort of visual confirmation for the segments marked for deletion?


As already said, when segment 1 is marked for deletion and then segment 2 is selected for the same purpose, in the pop-up window segment 3 appears instead.

Login to post a comment