CafeTran Espresso 2019 Forerunner

It is time to start rolling out the Forerunner (aka Preview) version of CafeTran Espresso 2019. This update and the subsequent builds this year will make up the CTE 2019 version to be released in December/January.


The update can be performed via Drag and Drop as follows:


1. Run CafeTran.


2. Download 20190105_update.zip file from here and place it on your desktop. Do not unzip or rename the file after downloading.


Note:   On Mac OSX system, Safari web browser may unzip the file automatically after downloading it. Before you download the update file, uncheck the  following Safari option:


Safari > Preferences > General > Open "safe" files after downloading.


3. Drag and Drop the downloaded 20190105-update.zip file anywhere in CafeTran's initial screen - the Dashboard.


Alternatively, you can install 20190105_update.zip file via the "Install Update" button in the Help > About panel instead of dragging and dropping.


Important! Please complete all your translation projects in your current CafeTran version before updating.


What's new in this update:


  • Autopilot. This may be a very handy feature during the Review or QA phase of translation. You can also use it when translating short, repetitive/similar phrases or numbers. It allows hands-free navigation with the set delay between the segments. The default delay of 2000 milliseconds (2 seconds) can be increased in Edit > Preferences > General tab. Activation/deactivation of the Autopilot is done via the Action menu. After that, you will notice the Autopilot button in the target segment editor. Click this button to turn on/off the Autopilot. Going to the next segment triggers off its functioning. To suspend it for a while (e.g for the correction of the current segment), press the Esc key or click the mouse on the target segment editor.
  • Automatic transfer of numbers being the full segments which end with the white space character.
  • Recognition of language variants in SDLTB termbases.
  • Support for subtitles (.itt and .srt file formats).
  • Added video resource preview for translation of subtitles.


Enjoy!

Igor


3 people like this

Hi Igor, do you think that this status related changes (permanently) and, most important, real (not virtual) merging/splitting segments for .sdlxliff files would be implemented at any time? I mean, can we count on it for the future?

_______________

"- highlighting punctuation characters in TM exact matches which are defined in "Do not match" option."As you can see in my screenshot, it's not working, I cannot see the parenthesis, coma, nor even the number in the corrected one.

Regarding this, I still see the way it shows the modifications quite deficient, the way ALL other tools do is simpler, save space (why to show two segments with each own differences instead of showing just one with everything?) and is understandable/readable at a glance (your "design" is as hard as to make it unusable).

______________

Last but not least, "- options for QA checks are stored in Project Templates.". I don't see the point of doing this through project templates, people not working with native CT projects, don't make use of project templates, it's just not possible.

 

I have the feeling that CT is in someway in the need of design improvements, those that should be done by a software designer and not by a developer (don't take this bad, CT is an amazing piece of software with the right tools and more, but the design, ergonomics, aesthetics and so on are not coupled at all with its potential)


Cheers


image



1 person likes this

The new update (2018111601) of CafeTran 2019 Forerunner is available for download. The changes are as follows:


- highlighting punctuation characters in TM exact matches which are defined in "Do not match" option.
- replacing background color with strike-through line for the missing words at the comparison between the current segment and fuzzy matches.
- new "R" symbol in the grid for repeated segments regardless of their propagation status.
- marking segments edited in the current session - see the red asterisk in the grid.
- showing the origin of the translation in the grid:
    - Machine Translation - see the MT symbol.
    - CafeTran's Auto-assembling - see the CT symbol.
    - Human Translation - see the HT symbol.

CafeTran handles the origin state automatically. For example, Machine Translations or Exact/Fuzzy matches switch to Human Translation (HT) state after their edition. Currently, the origin is stored permamently in CafeTran's projects only, as projects coming from other translation tools may not have this concept. There are also new filters corresponding to the new states:


- Segments edited in the current session - see Filter > Status menu.
- Human Translation (HT) - see Filter > Origin menu.
- AI Translation (MT+TM) - see Filter > Origin menu.


Please download and apply the update file as described in the first announcement post to this thread. Enjoy!


1 person likes this

After testing this just now, CafeTran displays the fuzzy match percentage (in black background, just like 100% and CM) if there was one in SDL Trados, coming from a TM during the project preparation, etc..


However, I don't think inserted matches are brought from CafeTran to SDL Trados.

 @Jean Dimitriadis

What about Studio fuzzy hits?


Here's how the various SDL Trados statuses that are mentioned in the green Notes appear in CafeTran (segment above the Note).


I have not tried fuzzy matches, but overall the situation is good, with the exception of signed-off/sign-off rejected statuses, which some PMs might apply. Using a combination of a Lock and green/red frame could be helpful here.


Usually, segments signed-off by PMs do NOT require editing by translators.



The new update (2018110802) of CafeTran 2019 Forerunner is available for download with the following change:


- options for QA checks are stored in Project Templates.


Please download and apply the update file as described in the first announcement post to this thread. Thanks!


1 person likes this

Try using Project > Export all documents, instead of "Export current document".

Hi again Jean, 


I followed your suggestion, but the file in the exported folder still has the country code. Does your CTE behave differently?

JeanA solution is to use multiple-file projects, even for one file. The exported folder bears the language code, the contain files do not.


This is an even better solution, thank you. I didn't know it exist at all. I'll try it out.

A solution is to use multiple-file projects, even for one file. The exported folder bears the language code, the contain files do not.

Igor: Added the "es" language code (neutral - without a country variant) for Spanish spoken in the US.


Would it be possible to let the user choose whether to add the country variant to the language code upon file export? I always find myself deleting it.


Thank you

>OFFTOPIC: isn't it AMAZING we, the users/translators, are shaping the software on the go because the developer is just here, listening all the time? This is priceless.


A) I don't think that this is off topico.


2. Yep, that's what amazed us too, years ago :).


III/. Spread the word.

OFFTOPIC: isn't it AMAZING we, the users/translators, are shaping the software on the go because the developer is just here, listening all the time? This is priceless.


1 person likes this

And just one last thing to fine tune Statuses, when a segment is "Checked", why not to "Uncheck" the segment if we type something on it after we "checked" it? This could avoid, for example, typing by mistake a checked segment and actually consider it as checked and not edited.

Read here and there (the whole thing, not only the first pages).


Short from here

The user needs to remove the curly apostrophe from the "Do not match" list in Edit > Preferences > Memory tab to have it matched. This should also work for straight ones.


1 person likes this
Login to post a comment