Start a new topic

Progress window frozen

 Every so often on opening CT the progress windows opens but stays frozen in the middle of the screen, no progress is shown, not even waiting for hours and CT is frozen. Force Quit on my Mac says Cafetran (not responding). I have assigned CT a Java Memory size of 10.240 MB, I have 17,37 GB free on my Mac.

On second or third try CT finally starts and opens the last project I worked on.

I know this is a known problem but I couldn't solve it so far. Any hints?


TIA

Wolfgang


Which OS version and which Java version?


Just as a reminder: In a not so far future, Java won't be supported any more (officially) by macOS.

OS 10.13.6, Java v8 Update 181 (build 1.8.0_181-b13). CT version is the very last released: 20180901_update

I would assume that newer versions are only tested with Java 10, but I don't know. I do not have any problems with this macOS version and Java 10 (but only 8 GB).

As far as my system is concerned it says I have the recommended Java version. But I had the problem before updating Java a couple of weeks ago.

it says I have the recommended Java version


I don't think macOS still gives reliable hints concerning Java (in other words: Apple does not care any more about this). 

progress windows


What kind of window shall this be? Here, CT pops up (well, not so fast as desired) and voilà.

Suppose it's the windows showing the progress whilst loading the TMX

TMs of what kind ("normal" or Total Recall) and of which size?

Quite plain TMX, 107 MB

Your Java on Mac is okay but CafeTran may still read some old Java memory settings (e.g. from 2015 or 2016 CT version). I would recommend resinstalling the program as follows:


1. Remove (put to the Trash bin) CafeTran.app from Applications folder.

2. Download from https://www.cafetran.com/download-for-mac  and install the latest version back in the same Applications folder.

3. Change the Java memory settings again. Do not put any full stops or commas in the set value.

4. Restart CafeTran and try loading your TM again.

Thanks Igor, will try that as soon as I have no projects running.

Before taking the plunge I checked inside Applications/Cafetran.app and realize that Resources/dabases in the Java folder weighs some 2,67 GB so I guess there might be something important in there which I wouldn't want to throw away. So shall I save this Database folder or not?

If you use Total Recall, don't put to Trash the old CafeTran.app. Just remove it from the Applications folder. Then, after installing the new CafeTran.app in the Applications, copy the large SQLiteMemoryBase.db file from inside the old CafeTran.app into the very same location inside the new CafeTran.app (overwriting the empty SQLiteMemoryBase.db there). If all goes well with new version, you can discard the old CafeTran.app.

That's what I did now. Cannot tell yet if the problem's been solved as it was quite erratic.

I still have two more databases in my old Java database folder, that is, H2MemoryBase.mv.db (2,6 GB) and H2MemoryBase trace.db (10,4 MB). Where do these belong to?

Login to post a comment