Start a new topic

Workflow in Caftran Espresso with Trados packages

 

 Hi,

My major client uses Trados (currently Trados 2017) and always sends me Trados packages to work with.
I tried Caftran Espresso for some projects, I really like the simplicity and the fast response of the software, and I wanted to get rid of Trados for a long time, because it is a) slow, b) buggy and c) way too expensive.

The problem is that the packages always come with an online TM and a termbase. I already figured out that I can convert the online TM to a TMX in Trados, and then use it in Cafetran.
This is a bit complicated, so is there a way around?
After completion of the work, I would like to perform a QA with X-Bench. How will this work in Espresso?

Thanks for your advice.

>The problem is that the packages always come with an online TM and a termbase. I already figured out that I can convert the online TM to a TMX in Trados, and then use it in Cafetran.

This is a bit complicated, so is there a way around?


Sorry, but no.


Suggestion: try to create an exclusive working relation with your client, so that you only have to do this conversion once.


>After completion of the work, I would like to perform a QA with X-Bench. How will this work in Espresso?


Only on the XLIFF file.


But hey, which QA categories are you missing in CafeTran Espresso 2018?


1 person likes this

Indeed. I actually also own a licence for Xbench, but never use it for QA, as CafeTran does everything I need. 


Also, if you ever find something is missing, Igor usually adds it to CafeTran's already formidable arsenal of QA modules pretty quickly, assuming he feels it would be of some use ... and you ask him nicely.


Michael

QA2.PNG
(40.7 KB)
QA1.PNG
(40.5 KB)

>assuming he feels it would be of some use ... and you ask him nicely.


And never name the other tool. :) This works counterproductive.

>Apparently there is no way round Trados for the extraction of the packages


Firstly: CafeTran Espresso 2018 will open them automatically


Secondly: Of course you can open these packages without Studio and extract the relevant info yourself.

 Here's another workaround I just thought, NOT TESTED: If the signed-off segments have a different status that the to be translated segments in CafeTran, then filter these by status (Filter > Status submenu), and use Task > Lock segments. These are only locked for the CafeTran session, not in Studio (or if you restart CafeTran). Normally, locked segments should not get the Translated status when you finalize file or export to package. Please confirm this if you test it.


I have to try it when I have time, but as I remember the segments with the status "signed-off" have the status "not translated" in Espresso.

Now I have another problem with the Trados package in Espresso:


When I open the package in Espresso, it will creat a SDL Trados Studio Project File (.sdlproj). I am not able to open this file with Trados. I get the message "The selected project could not be opened." every time I try. Any idea how to solve this?

> I am not able to open this file with Trados


You are not supposed to open this single file (.sdlproj) in Trados. You can only open the whole translated package after exporting the translation back to package  via Project > Export and exchange > To package... 


OK, just did a test, and here are some Trados statuses as mapped in CafeTran.


image


Signed off segments are being displayed as "Checked" in CafeTran (grey background), and Translated as "Approved" (gray background, red frame).


So yes, you can try the following workaround:


- (Optional) Filter the signed-off segments by status (Filter > Status submenu), and use Task > Lock segments. The lock is for the session only.

- (Optional) You can uncheck Action > Skip > Locked segments if you wish so.

- Translate the non signed-off segments, those that do not have the grey background.

- Filter the translated segments, and use Task > Set Approved (translated) status to these segments.

DO NOT hit the Finalize button, as it will set the status to all segments.


At any rate, please test and report back.


Also, I don't think there is a way to do this for packages. It requires manually expanding them and translating the included SDLXLIFF or SDLXLIFFs (in the second case, via Dashboard button > Multiple documents projects).


Igor, can you confirm if there is another way to export Trados packages while preserving some segment statuses?


Jean


The exported packages need do have the segments with the Translated status set. Otherwise, more often than not, your client will complain.

Yes, I understand the logic. Anyway, it is always possible to translate the SDLXLIFF files instead, so the workaround exists, if someone needs to preserve some statuses.


Please note reviewers/proofreaders are normally expected to use the "Translation approved" (and "Translation rejected") statuses in SDL Trados. "Translation approved" cannot be set or displayed from inside CafeTran, for review/proofreading jobs.

You are not supposed to open this single file (.sdlproj) in Trados. You can only open the whole translated package after exporting the translation back to package  via Project > Export and exchange > To package..


Well, I am able to open this file when I opened the package with Trados. Just doubleclick on it, Trados opens and I can start to work.

There is yet another problem with Trados packages: I got a package with segments where the target segment are filled with the text from the source segment and in the status "Not translated". When I open it in Trados, I can use a filter and display the segments with the status "not translated". This filter doesn't work in Espresso, these segment have the status "translated", and the filter doesn't sort out the untranslated ones.

Any idea how to handle this? Thanks for the advice.

Yes, the SDLPROJ file can be double-clicked to open a project in SDL Trados.


External CAT tools (not just CafeTran) can only handle the SDLXLIFF files or packages with SDLXLIFF files that contain the actual translation segments.


Please ask/use SDLXLIFF files or SDLPPX packages instead.


---


Status "Not translated":


- Since you have access to SDL Trados, you can filter these segments and remove the target text, before opening the files in CafeTran.

- Alternatively, in CafeTran, you can use Task > Remove target segments same as source to remove the content of target segments that just feature the source text. Then proceed with the translation of empty segments (by filtering them or by using the shortcut for Action > Add segment to memory and go to next untranslated segment). I also suggest you back up your files before doing so.


Jean

That's interesting, I have never thought that Espresso does a better QA than Trados. I have to try it out, so I can save two licenses in the future. Apparently there is no way round Trados for the extraction of the packages, but at least I don't need a new license for it. It won't work to make an arrangement with my customer.

I finally found time to use Cafetran for a small SDL package, and I am still loving it. However, there occured wone problem:


The original file had a lot of segments in the status "Signed off". After I translated it with Espresso and reopened it in Trados, the status of these segments turned to "Translated". This causes a problem, because I don't know which segments I translated and which not.


Thanks for the help!

Login to post a comment