Start a new topic

Number localization

Hi all,

I am currently translating a document with lots of decimal numbers from English into Spanish, and I can't find the way to switch on automatic formatting to convert decimal points into commas. I've read in a couple of places that this is achieved by selecting "Format number" in the auto-assembling preference menu, but I tried it and it has no effect. What am I doing wrong? Most of my segments consist in a single, isolated number.

A related question: I have an endlessly-repeating segment consisting of the string "1.5 months", pre-translated as "1.5 meses" by CT and which I should translate as "1,5 meses". No matter what I do (find and replace or autopropagate), I'm unable to change them with a single edit: they will stay as "1.5 meses" unless I edit each segment separately. What might be preventing CT from accepting and propagating my massive edit? 


Thank you,

Valentina


Hi Valentina,


If you deselect "Format numbers" in Auto-assembling options, then Auto-propagation of one single edit for the given segment should propagate that edit for the identical segments unchanged, that is, without changing your edit/formatting your number.  Also, you might experiment with "Transfer numbers to matches" option in Auto-assembling preferences (for new segments).


Igor

Uhm... unsure it solves my problem. Yesterday the wrong format kept popping up no matter what I did with the "Format numbers" option. Today I decided to reset the whole configuration, and the autopropagation works fine.
Bottom line: I really don't understand how these options interact with each other, and yesterday I must have been using a perverse combination of settings. It is clear I will have to experiment to understand how it works.
For the time being, let me ask one question: how can I edit a single segment while preventing it to autopropagate to the rest of segments?

Thanks,
Valentina

Hi again, 
I just found the answer in this post from last year:


>To turn off the auto-propagation of the current segment, just right-click at the source segment and >uncheck Autopropagation item in the pop-up menu  - the feature is available in recent CafeTran Espresso >2017 Yeddi updates.

Thanks anyway!

Login to post a comment