Start a new topic

Number localization

Hi all,

I am currently translating a document with lots of decimal numbers from English into Spanish, and I can't find the way to switch on automatic formatting to convert decimal points into commas. I've read in a couple of places that this is achieved by selecting "Format number" in the auto-assembling preference menu, but I tried it and it has no effect. What am I doing wrong? Most of my segments consist in a single, isolated number.

A related question: I have an endlessly-repeating segment consisting of the string "1.5 months", pre-translated as "1.5 meses" by CT and which I should translate as "1,5 meses". No matter what I do (find and replace or autopropagate), I'm unable to change them with a single edit: they will stay as "1.5 meses" unless I edit each segment separately. What might be preventing CT from accepting and propagating my massive edit? 


Thank you,

Valentina


Hi Valentina,


If you deselect "Format numbers" in Auto-assembling options, then Auto-propagation of one single edit for the given segment should propagate that edit for the identical segments unchanged, that is, without changing your edit/formatting your number.  Also, you might experiment with "Transfer numbers to matches" option in Auto-assembling preferences (for new segments).


Igor

Uhm... unsure it solves my problem. Yesterday the wrong format kept popping up no matter what I did with the "Format numbers" option. Today I decided to reset the whole configuration, and the autopropagation works fine.
Bottom line: I really don't understand how these options interact with each other, and yesterday I must have been using a perverse combination of settings. It is clear I will have to experiment to understand how it works.
For the time being, let me ask one question: how can I edit a single segment while preventing it to autopropagate to the rest of segments?

Thanks,
Valentina

Hi again, 
I just found the answer in this post from last year:


>To turn off the auto-propagation of the current segment, just right-click at the source segment and >uncheck Autopropagation item in the pop-up menu  - the feature is available in recent CafeTran Espresso >2017 Yeddi updates.

Thanks anyway!

Hi,


I seem to have a recurring problem with number localisation (as you can see from my previous posts in this thread). Briefly: I cannot find a robust way to transfer decimals automatically (i.e. 104.5 -> 104,5), not even in the simplest case of segments consisting of one isolated decimal and nothing else. At some point, I had come to the conclusion that the combination

Transfer number to matches

Format numbers

was the one I was looking for, but then it stops working - even within an ongoing project without any (conscious at least) change to the settings. I've tried to close and reopen the project, to quit CTE, to untick and then re-tick the relevant options, but nothing changes. What am I doing wrong?

Thank you for your help,
Valentina



Hi Valentina,


> Transfer number to matches

> Format numbers


If you set the correct language pair for your projects, CafeTran transfers to the  source segment and changes the format of the non-translatable numbers (e.g 104.5 highlighted in pink) in fuzzy matches, machine translation and auto-assembling results. It does it at the moment of transferring the result from the Matchboard (or a TM pane) to the target segment editor via clicking at the result or using a keyboard shortcut. It also formats the non-translatable numbers as you transfer them from the source to the target segment - use F4 shortcut to list them. Also, make sure you are using some recent version of CTE.

Hi Igor,

I'm using Akua 2018 update 7, language pair en-US/es-ES. I see the translatable numbers highlighted in pink, but they are not transferred anywhere (see attached screenshot). As I said, a couple of days ago, same project, same file, they did.

Thank you for your help.  

Please make sure that the option "Transfer numbers to matches" in Edit > Preferences > Auto-assembling tab is activated.

Yes, it is. 

Hi,


the problem is that even with the function Replace characters at source transfer switched on, CF can't convert commas into points and points into commas at the same time. With the settings of the said fuction as follows:

1) . ,

2) , .

3) boxes left blank


 it will convert everything into points.

It doesn't work as it should, I think.


I believe it would be useful if a user also could mark a string of numbers and convert it with, say, a right-click - i.e. semiautomatically, according to one's settings.


                                                                         Regards


                                                                      Wojciech

Perhaps one of your TMX Memories is very large or corrupted. I can't see the Assembled result in the Matchboard (in your screenshot), so the program may be still searching for the results. If the TMX was corrupted you wouldn't see any results in the tab with this TM. Please check your "Previous TMX" TM. You can close it to see if auto-assembling works after closing.  Or you may have deactivated the display of auto-assembling results?

I've got rid of all memories now and still no results. I'm not sure about the display of auto-assembling results: how do I do it?

PD 
Btw, I closed the project and re-opened it again after getting rid of memories.

You can submit a support ticket attaching a packaged .ctp project with segments as in your screenshot (if this is a native project created in CafeTran). Save it to the package via Project > Export and Exchange > To Package... . 

Some of the numbers in your project are trailed with an additional character - the ending white space. For now, CafeTran cannot auto-transfer such numbers. Perhaps, the next update will be able to handle such cases. 

Login to post a comment