Start a new topic

Memory > Import segments from project not working

Following scenario:

  • Finish project on machine 1 (4K words, new client, new TM)
  • Proofread and edit file on a 2nd machine and then reopen on 1. machine
  • Memory > Import segments from project
  • „Action completed“ is being displayed
  • Open a 2nd, simlar project with many repetitions from the 1st project
  • I get constantly wrong matches, the TM did obviously not take into account the changes – why?

This is really hilarious.


The Import segments from project works as follows:


1. Select the tab with the TM you wish to import to. It can't be a memory set as read-only.

2. Choose the Memory > Import segments from project.

3, Save the TM via Memory > Save memory... .


Alternatively, the user can choose Project > Export and exchange > To TMX memory... .


Both methods work just fine.

The issue might be that CT gets back to me "Action completed", but the action has not completed, no matter for what reason (tab not in the foreground, buffer overflow etc.). There is no sense to work with a tool that you need to mistrust, as it claims sth happens that did not happen. That's the point here.

 

 > tab not in the foreground


In that case, the action might have been completed in another translation memory if the user opened a few translation memories. Just follow the steps outlined above selecting a tab with your chosen TM first.


Your scenario involving more than one computer is too general to follow. This is a good practice to narrow down the procedure as much as you can when reporting an issue. This way the developer may be able to reproduce it easily confirming it or not. For example, when you check the bug reports for Java (https://bugs.java.com/), you will notice how detailed the reports are with reproducible tests from the users. I don't require as many details here but nevertheless, at least, you might perform one more test narrowing it down to one machine and one operating system whatever it is. 

No problem to reproduce it:
  • Open file with translated or checked segments.
  • Only one TM opened.
  • Memory > Import segments
  • TM tab not opened
  • > Dialogue box "Action completed" is triggered
Sometimes it happens, sometimes not. Knowing that might lead to reconsider that and to keep the TM tab at top at this very moment (even a bit more experienced users might forget that). But for most beginners this is a severe bug, indeed.

Expected behaviour:
  • dialog box to choose TM (in case several TMs are open), same as for other commands
  • import works as expected or error message is being thrown out, no matter whether the TM tab is on top

 


> TM tab not opened


You miss one important step to select the tab with your TM. The expected behavior is the one as it was designed (and outlined above). Of course, you may suggest/request for improving the design or user's error handling (e.g by reminding of choosing the specific tab with your TM to tell CTE which TM you have in mind).

Indeed, e.g. a dialog box to check the TM as when removing duplicte entries.

 

But it is absolutely fatal to get a message "Action completed" when nothing at all has happened. IMHO this must not be the case, never, no matter how the task has been designed. Things should be kept simple, but this is far too simple and misleading.

Now that the feature is implemented, it constantly shows all TMs, no matter whether read-only or not.

Even read-only memories are updated. Nice, but not the sense of the word Read-only. Shouldn't there be a small visual sign (an asterisc) to mark the read-only memories? I did not test this with TMs in Studio packages, I wonder what will happen then.

Read-only means you cannot write to the file.

Igor, is "Memory>Import>Import segments from project" and "Project>Export>to TMX" the exact same thing?

My understanding is that the "import" option will add segments to an existing memory and "export to TMX" will overwrite the memory. Or do I lose my existing memory when doing "import segments from project"?


Thanks!

"Memory>Import>Import segments from project" imports the project segment to a selected (and already loaded) TM.


"Project>Export>to TMX" exports project segments to a new TMX file.

Hello,


I'm experiencing a problem, too. Memory>Import>Import segments from project leaves the memory empty, it says "Action completed", but segment units are =0, why? The memory is not read-only.


Thanks for any help,


Elisabetta

Hello Elisabetta,


If you are using a recent version of the program, you should see the memory selection panel before the import starts.  After confirming/selecting the TM, the import takes place for the translated segments (with the target side filled) only. Also, make sure that your project language pair is the same as the TM's language pair and refresh the TM view after the import.

Hello Igor,


that was exactly what I did, but I still got "segment units = 0", even after saving the TM. The only difference is "refreshing the TM", as you advised to do. As I don't know how to "refresh" :-) I've simply closed and reopened the TM and everything was in place!


Thank you!


Elisabetta

> As I don't know how to "refresh" :-)


Right-click at the TM pane (under tab's title) and select either Back or Forward green arrow. Those two actions can also be performed via the same green arrows in the Search bar at the top.

Login to post a comment