Start a new topic

REQ: Converting memsource tags upon import

 Hello,


I would like to request that CT converts memsource file (.mxliff) tags into CT types upon import.


Now, an mxliff file appears like this in CT.


image


Memsource tags can be properly handled by SDL Trados, and an sdlxliff file created by it (with the tags converted into serial numbers) looks like this in CT.


image



My request is to get this without intervention of SDL Trados.


I'm willing to send you a sample mxliff file if needed.


They appear to be some internal markings unrelated to the xliff format itself but rather to the source document being translated. In CafeTran, you might add them to nontranslatables in the form of the regular expression such as:


|[{<]\d+[>}]


Then, they will be highlighted and transferred easily as nontranslatables.



Thanks for the advice.

>> They appear to be some internal markings unrelated to the xliff format itself but rather to the source document being translated.

I don't know. The relevant portion of the xliff file is:

<source>Whereas, XXX is engaged in {1&gt;the business of &lt;1}{2&gt;design, specification, marketing, sales and services of promotional and advertising materials&lt;2}{3&gt; and,&lt;3} in connection with such business, would benefit from receiving the services that are {4&gt;agreed from time to time between the parties &lt;4}hereto;</source>

 Anyway, at least for the time being, SDL Trados Studio can be a good help.

Igor,


Just to learn: why are you enclosing {< and >} with brackets here?


image

And regarding my constant request for a regular expression tagger: perhaps this could be made superflous by allowing non-translatables to be collapsed? Don't know.



Apart from a Regex Tagger feature, which looks nice, there is concern that these non-translatables may considerably lower TM matching rates just because of their presence/absence. Can I exclude them from matching by inserting your regex in the "Do not match" section of the memory settings panel?

 

>concern that these non-translatables may considerably lower TM matching rates just because of their presence/absence


So true!

> why are you enclosing {< and >} with brackets here?


See Character classes here: https://docs.oracle.com/javase/8/docs/api/java/util/regex/Pattern.html


Can I exclude them from matching by inserting your regex in the "Do not match" section of the memory settings panel?


Yes you can, except for numbers.


Login to post a comment