CafeTran Espresso 2017 - Yeddi Update 18

Hi,

 

CafeTran Espresso 2017 Yeddi update 18 is available for download. The update can be performed via the Drag & Drop procedure as follows:


1. Run CafeTran.

2. Download 20170731_update.zip file from here (do not unzip or rename the file after downloading) and place it on your desktop.


Note: On Mac OSX, the Safari web browser may unzip the file automatically after downloading. To prevent this, just use the right-click menu and choose the "Download Linked File" command.

 

3. Drag and drop the downloaded file into the Project Dashboard and restart the program.


Alternatively, you can install the update via the Update button in the Help > About panel instead of dragging and dropping.


What's new:


The update 18 brings the following improvements:

  1. A keyboard shortcut for "Delete segment" in translation memory edit mode.
  2. Access to Preferences from the Dashboard menu.
  3. Project > Export and Exchange > To TMX memory... and Memory > Import > Import project segments take the filter state into account during segments' transfer. For example, the user can open a translation memory in the edit mode, create a range filter by typing segment's numbers range (e.g. 1000-2000) in the Search field, and then transfer the filtered segments to the new translation memory.
  4. A new bright theme for Dashboard.
  5. A few minor fixes.

 

Igor


Thanks for mentioning the new build here too.

In https://cafetran.freshdesk.com/support/discussions/topics/6000050186


Igor wrote:


In today's build of update 18 - 2017080101, the Document note opens automatically in CafeTran's projects. Also, when you quit the program and your note has been edited, CafeTran asks in you wish to save it. Please download and apply the update 18 again.

Weird. Got it working again. I went back one day in time with Macrium Reflect, and then installed the latest update again, and now it works fine. I had also messed around with other programs. That was probably what caused it.

I can't open any older projects either, even one from two days ago. It just hangs endlessly on "Loading project units...".

Hmm, anyone else having problems with the latest update? I am suddenly having all kinds of trouble. Can't open docs properly. CT keeps showing me only one segment of the doc. Not sure what I did wrong.


I'm running CT Espresso 2017080101 (aka 2017-08-01#01)

Gotcha!


Michael


PS: am enjoying MySQL, as it imports faster. 


Still not sure whether I will end up using Total Recall or LogiTerm in the long run, for managing large TMs.

Not sure why, but updates seem to be erasing my MySQL settings


Yes, it provides the updated version of clean MySQL.res file for users who update straight from old CT versions - 2015 and 2016. It will be removed from new updates in the near future. 


1 person likes this

The craft was launched on April 11, 1970, at 13:13 CST (19:13 UTC) from the Kennedy Space Center, Florida, but the lunar landing was aborted after an oxygen tank exploded two days later, crippling the Service Module (SM) upon which the Command Module (CM) had depended. Despite great hardship caused by limited power, loss of cabin heat, shortage of potable water, and the critical need to make makeshift repairs to the carbon dioxide removal system, the crew returned safely to Earth on April 17, 1970, six hours after lunch.

 > You nasty old bastard.


:) Please don't get it wrong. I admire the strive for perfection - although the one with touch of improvisation and venture. If you know the story of Apollo 13 mission, you should get the point.

I think the TMX editor should be 100% free and unlimited. 


It would be a clever way of getting people to start using CT who might otherwise not have. There are a lot of people out there using the now open source Heartsome TMX editor, the very old Olifant, and a lot of other less known ones (anyone have a better list btw?). Any of these people could become future CT users if they started using CT just as a TMX editor and then got curious. 


My list:

 1. Heartsome TMX editor (https://github.com/heartsome/tmxeditor8)

 2. Olifant (http://okapi.sourceforge.net/downloads.html)

 3. TMX editor (beta) (https://sourceforge.net/projects/tmxeditor/)

 4. TMX Localization Editor (http://tmx-editor.sourceforge.net)(https://sourceforge.net/projects/tmx-editor/files/) (last version 2008)

 5. Stingray Document Aligner (http://www.maxprograms.com/products/stingray.html)

 6. Logrus TMX Editor 2.3 (http://www.logrus.ru/pages/en-tmxeditor.aspx)

 7. TMX Assistant - Translation memory library and editor. (OSX) (http://localworks.pl/tmxassistant/ + https://www.macupdate.com/app/mac/45992/tmx-assistant) (2013)

 8. CafeTran

 9. memoQ

10. etc.


And the next thing, the very next thing, will be that the aforementioned, plus the Count of Hastings of course, will complain that CT offering editing TMX files without offering the same features to tab del glossaries is unfair. BE WARNED!


H.

IK: Steve Jobs is smiling from above.


You nasty old bastard.


H.

Don't worry, Lenting and Torsten will soon let you know.


Yep, it's great to have perfectionists on board. Steve Jobs is smiling from above. :)

Concerning the trail version's limit: No, this is really difficult, and I do not think to make it free is the best solution. It must be an economical decision, not a ideological or philanthrope one. In the current state it can make sense to license a copy of CT and use it only as TM editor (depending on your needs).


I wonder how many steps are still there? ;)


Uh, don't worry, there are enough ideas to pick up and come around the corner with them (see posting above this one). Dragging sdltm files on the dashboard and triggering the "Edit TMX memory / Add TM" dialog box would be one (bigger) of them.


But okay, the Edit TM mode was a feature I only discovered by accident.

IK: I wonder how many steps are still there?


Don't worry, Lenting and Torsten will soon let you know.


H.

Login to post a comment