Start a new topic

Basic formatting not being saved in my Project TM.

I activated "Processing tags" when creating my ProjectTM, but when I add e.g. italics or bold to a particular segment, when I next get a match for the same TU, the italics or bold are not automatically added in the target box.


I checked the TMX, and the switch is On:


{prop type="x-processing_tags"}true{/prop}


What am I doing wrong here?


Michael


Two things come to mind: did you reload the memory of the change in the properties? And are you absolutely sure that the segments are completely identical? Sometimes they look identical but there are minor differences, but that prevent insertion of the tags.
After the change
OK, checked both those things. It's not either of them.

I then created a cpompletely fresh project, just to be sure, and I can confirm that no tags are being saved to my fresh ProjectTM.tmx, which was created with "Processing tags" set to ON. Hmm. Igor?

 

CafeTran can store in TMX the positions of transferred formatting tags but it does not save the custom tags. If  CT could do it, it would need to put them inline with the segments contents, making the reuse of such segments as fuzzy matches (or exact matches in similar segments with no formatting) much harder. This is a sort of trade-off between the reuse and exactness.

Hi Igor, but even the positions are not being saved to the TMX.

Basically, I just want to be able to not lose all the italics/bold I save to my TMs as I go forward.

 

> but even the positions are not being saved to the TMX.


Do you transfer the formatting via tags present in the source or apply the custom formatting to target? The positions of transferred tags should be stored in the unit's properties.

I'm applying custom formatting to target.

 

(using the keyboard shortcuts, if this makes any difference: Ctrl+I and Ctrl+B)

 

CT removes such tags from TMX segments. Why don't you transfer them via red numbers (type a tag number and press Escape) or a mouse holding CTRL button and selecting a phrase? Then, they will be remembered.

I can't transfer them because they are not present in the source.

Is there any way to force CT not to remove such tags from TMX segments? I sometimes add a lot of italics to my texts, but really don't want to have to re-add it all three weeks from now on a future project.

 

That's not possible. However, you might try the workaround via find & replace. For example, find all instances of a word in target segments and replace it with <i>word</i> (italics) or <b>word</b> (bold). If I come up with a quick solution to include custom tags when the Processing tags option is on, the update will be available right away.

How about something along the lines of: currently, CT can store tag positions in TU's prop field. How about also allowing it to store a little letter code for start italics (is), end italics (ie), start bold (sb), end bold (be). That way basic formatting could also be stored along with the TU, but not in the actual text. Or am I making zero sense here? So instead of just tag positions: 1, 6
you'd have:
1is, 6ie

meaning: italics start at position 1 and end at position 6

Anyway, it's been a while, but I think I'm back again, livin' the CafeLife! Decided to switch from Déjà Vu X3 to CT in the middle of a project today, as I really like CT's Match Bar and how it's easier to quickly get at terminology than in any other current CAT tool.

 

How about Dictafoon? Does that work for you now? if I remember correctly, this was your reason to shop elsewhere?
I had various reasons to shop around, but I recently realised that the ability to select dictated words by voice (which Déjà Vu offers) was not as important as good terminology support, like in CT. You live and learn. Slowly, painfully and blindly.

 

Login to post a comment