Start a new topic

Cafetran using 40% - 69% of CPU on Macbook

Hi --

I've just bought a new Macbook Pro and when I run Cafetran on it, the computer heats up to the point that it is uncomfortably hot to the touch near the location of the vents at the top edge of the computer body. I don't have a utility to measure temperature, but Activity Monitor tells me that Cafetran is using 40% to 69% of CPU even sitting in the background with nothing actively going on in the program. Constantly, for as long as I have it running.


I have been very happy with Cafetran and would hate to lose the utility of the program, but I'm not ready to fry my new Macbook, nor to ruin the battery from the heat. Is this normal behavior for Cafetran on a Macbook? I see that someone in another thread had a similar problem--albeit not as severe as mine--on a Macbook with similar specs but a 2014 model. Mine is a 2015 model, running OS Sierra. I would be very grateful for any ideas on how to get around this problem. I would really like to keep working with Cafetran, it's a fantastic program.


Thanks.


THAT'S IT!!! After switching to the metal appearance option, CT's CPU usage is ranging between 1.x at idle and around 8 when I'm using it. What a difference. Since the metal option doesn't integrate Cafetran into the Apple top menu, the problem must have something to do with that. Thanks a bunch—I was really afraid I was going to lose the use of CT. You saved me, Igor.


1 person likes this

Using metal look also brought down cpu usage and battery drain (a lot) on my macbook pro. However, and in case some were wondering, be aware that some short-cuts have changed. For example cmd-c and -v are now ctrl-c and -v.

Thanks for the confirmation, Julie. Perhaps the kbs can be changed, Igor ?

Are you, by any chance, using dictation too, just like Patrick?


For what it's worth: recently I had my iMac repaired and used my MacBook Pro for several weeks. With no heat related problems.


Do you have enough RAM?

On my iMac now: 0,6 % in background, 15-22% when in foreground. Is it really a MacBook related issue? Not sure.

I am in fact running dictation, although I actually use it only occasionally. But it's there in the background if I hit the fn key twice. If turning it off makes a difference, I'll try that. I have 8 GB of RAM and an i5. My old Windows computer has the same RAM but an i7, but the Macbook consistently does everything better, except Cafetran. Let me try turning off dictation and seeing if that makes a difference.

I have just checked it on Mac mini (late 2014 with 8 GB RAM). The Activity monitor shows 2.5-3.0 when CT is in the background and 15-20% when it is in the focus. Of course, the CPU jumps when performing processor intensive actions such as the search and auto-assembling but after that it goes down to around 15% again. 

I tried turning off dication and that may have made a very minimal difference. Watching the Activity Monitor as I work, I see that Cafetran is taking right around 40% as I type, and then briefly surges to 70%+ just after I clear the unit, before dropping back down to around 40% again.


Igor, is it possible that this is a problem that's only occurring with OS Sierra and not earlier versions?

I test it on macOS Sierra here. It is not Macbook though. Perhaps, the internal Java web browser included in CafeTran takes that processing power? Try to open CafeTran without any web resources and see if it makes any difference. Did you change the Java memory settings in Edit > Preferences > Memory tab? Try to increase it to 4096 and restart. 

Yes, I've already done both of those things, Igor, and unfortunately the problem persists. I was just about to try opening another project just to see whether that might make a difference, but I guess it's difficult to see how it would.

No, I tried opening other projects to see if I could get different behavior, but nothing changed :(

Another idea is to update Java to its latest version (currently Java 8 update 131). Also, Oracle is to release Java 9 in July. New versions should integrate better with the OS.

Okay, thanks, I'll try updating, but I may have the latest version already -- I just installed Java on the computer this week.

No, indeed I have the latest version of Java on the computer already. It also occurred to me that the fact I had an image background might drive the energy consumption up, so I went to the default background, but that, too, did nothing to fix the problem.

Login to post a comment