Start a new topic

Autocompletion, hyphenated words and segments with a fuzzy hit

 Hello all!

I've been using Cafetran with some longer projects for a week or so and am really enjoying it.

However, I still have plenty to learn and really a list of question the length of my arm.

Some things I've definitely missed from the documentation etc., but there are a few questions I wonder if someone here can answer.

I've been using Cafetran on Ubuntu, if that is at all relevant

1) Autocompletion... great, but it doesn't seem to work e.g. when editing a segment _unless_ there is a space after where you are typing.


Source sentence: "This is a source sentence"

Target sentence "This is a target sentence"

If you double-click "source " (i.e. also selecting the space at the end) and start typing "tar...", autocompletion doesn't start for me - even after three characters - unless I put a space in after it. Can be frustrating when I know it should autocomplete

2) Hyphens

I work from German and German writers just _love_ a hyphen. Cafetran seems to treat words separated by a hyphen slightly differently than e.g. memoQ.

For example, for the string "one-hyphen", if I go to the end of the string and press Ctrl+Left e.g. in this post window or in memoQ or in Word, it takes me to the end of the hyphen, not the beginning of the string. In Cafetran, it takes me to the beginning of the string. Why is that? Trying to select some text in German source segments is quite frustrating as a result.

3) Fuzzy matches are also great...

... but I can't work out how to stop Cafetran treating fuzzy match segments as translated. As soon as a fuzzy match is inserted, Cafetran skips the segment (when I have "Skip translated segments" selected).

So, I've just finished one segment and press Alt+Down. A fuzzy match is inserted in that segment, then I think "Oh! I missed something in the previous segment" and click on it again, edit it, then press Alt+Down again, but now it _skips_ the segment with a fuzzy match, even though I never pressed Alt+Down in the second segment. Am I doing something wrong?

4) On a similar theme, how do you get Cafetran to just go back to whatever segment you were working on before the segment you are currently in?

It may be lazy on my part, but I constantly use Ctrl+Z e.g. in memoQ as a quick way to skip back to the last segment if I realise I've missed something just as I finish the segment. If I've got e.g. "Skip translated segments" selected and Cafetran automatically skips a lot of segments before the next untranslated, I can't see how you can easily get back to segment you were just working on.

Just a few things then!

Any help or suggestions would be much appreciated.


1. When you double-click a word (with the mouse), the space behind the word usually is not selected. It would be nice to have the same for selection with the keyboard. The fact that autocompletion only starts when there is a space behind (but also e.g. a hyphen or parenthesis) might be due to the problem that this could result in heavy performance issues as any keystroke could trigger auto-completion in a word then.
2. This is the typical behavior, but this is java-related (OmegaT has the same "issue"), I suppose. Together with point 1 an ungood mix, sometimes.
3. One of the first things to learn in CT is the difference between translated and checked segments. Simply untick "Skip translated segments" and get used to set segments to the state "Checked". Unfortunately there are some glitches with Studio packages and files (where the state gets reverted sometimes), but this is another point.
4. Ctrl-Z works in CT, too. Maybe you need to type it twice (on Mac I must). If this happens regularly, you might prefer to use "Add checked segment to memory and go to next segment" instead of "Add checked segment to memory and go to next unchecked segment". Then no segment will be skipped.


Hope this helps.

Hi John,

1. If wish to trigger auto-completion in the middle of the word, please use CTRL+down (arrow) shortcut.

2. That's Java way of recognizing words in the editing widgets. After reading your post, I quickly googled and was surprised a bit finding no complaints. In my opinion, it is hard to determine whether the hyphen separates two words or the whole hyphenated phrase should be treated as one word. Java (Swing user interface library) programmers decided the latter. It may be possible to overwrite the designed behavior so I will make note of it and experiment.

3. Torsten's suggestion might work for you. In CafeTran, 'Translated' means the non-empty target segment, so you might need to use 'Checked' status.

4. CTRL-Z means undo your last edit in the target segment editor. You may wish to use "move to the previous segment" command (ALT-Left shortcut on Windows). 

Thanks for the replies!
Really useful info.
I'm too far into my current project to try "checked" instead of "translated" (I think I'll get very confused...), but it sounds like using Checked is essential. Will "Checked" also set the target segments to "Translated" in any SDL target package?

About point 4):
ALT-Left seems to skip segments in just the same way as e.g. ALT-Down, so if I've already set the segment to translated/checked, it would skip that segment as well, wouldn't it?
I suppose what I want is some command to "move to the last segment I edited before I arrived at this segment". It's really just poor technique on my part, but I've got so used to 'confirming' a segment while I'm still scanning it for errors.

Thanks for your help!


In CT, 'Checked' maps to ApprovedSignOff status for sdlxliff files. You can set the 'Translated' status for all the segments via the Task menu. CafeTran also does it automatically after you click the Finalize button which appears when you translate the sdlxiff files.


I'm not sure if Checked status does something more than Translated for SDLXLIFF files when exporting, but when you finish the translation of an SDLXLIFF file, you'll notice the usual Export button says Finalize. When you press it and confirm the choice, it propagates the Translated status to all segments (you get a message confirming this action), which you can doucle-check by opening the file in Trados.

ALT-Left / ALT-Right helps move to previous and next segment without affecting the TM. ALT+Down adds the segment to the TM before moving to next segment.

For skipping segments, you might want to see the:  Action>Skip menu for Skip options, or check if Filtering segments (Filter menu) might help.


I don't know how to "go to last segment I edited" (in general, that's just ALT+Left), but then again, I tend to have a pretty good idea of where I am in the file (segment numbers and such) or remember source/target wording, and searching/finding things in CT is a breeze.

You can force entering the segment which should be normally skipped either by clicking its number in the segments grid or typing the number in the search field followed by ENTER. 

> please use CTRL+down (arrow) shortcut

Feeling a bit stunned: I am using CT for some time now and ignored this absolutely. This should be highligthed in the Help/Solutions.


OK, I've been using these tricks a bit more.

CTRL+down is really useful, particularly e.g. if you're editing a segment and just need to change a single term to an alternative in the glossary.

The Translated/Checked statuses also work as I wanted, but it's made me notice that highlighting of the current segment in the segment window is not very clear (just a black border, isn't it?). It's actually even more of an issue with QA, when I have been looking at the wrong segment sometimes in the segment window... Is it possible to use some super-bright colour for the current/active segment in the segment window? Maybe also colours for the different segment statuses? DVX does this really well...

I still don't think I have a foolproof way to find the last segment I was working on...
Alt+Left still skips the same segments as Alt+Down, so - if I have set my previous segment to checked already - it will skip it if I have it set to skip checked segments, but will just go through all the segments between the previous segment I was working on and the current segment if I do not set it to skip checked segments.
Clicking the segment number also isn't very useful if the last jump skipped lots of segments, because you would have to cycle back through the "pages" or remember the number of the previous segment. The problem then is that, if I have set a segment filter and then cancelled it, the numbering changes anyway...

 Lastly, some TM points!

1) Whenever I opened/closed my last big SDLPPX project, I had to reopen the SDLTM, which was OK because it is fast, but then it started preliminary matching every time, which took quite a while in the background and quite a lots of my resources (3GB RAM/20% CPU). Why doesn't it just do this once? Or is there a way to permanently link the SDLTM to the project and save the preliminary matching data?

2) I messed up my TMs a bit by failing to set the TM from my client as read-only and it took a while to realise I was sending my translations to ALL my TMs (obviously, not what I wanted to do). It was only when CT asked me to save the data that I noticed.

Thinking of other tools.... DVX has a nice list with "Read" "Write" and "Lookup" checkboxes (or something like that). Some sort of list of TMs in the project with these settings would be great - or maybe just a lock symbol on locked TMs. Just thinking!

Thanks again to all for your help.

Just a side note:

Using "Checked" rather than "Translated" also seems to be essential if you have fuzzy matches in a Studio package, because fuzzy matches are treated as "Translated" as well, even if you have selected not to skip "Auto-assembling and fuzzy matches".
And there doesn't seem to be a way to filter on fuzzy matches only either.
So if you use Translated, you'll just quite happily skip all the fuzzy matches your PM created....


Additional issue with "Checked" status and SDL packages!
CT doesn't 'remember' checked status if you export your files, close/reopen the project.
Given the above, this is pretty maddening...


Given that CT also takes an age to do "preliminary matching" for Total Recall and other large TMs each time I open/reopen an SDL project, it seems that the only solution is to keep CT open until you've finished the job. Otherwise you:

1) Lose "Checked" status (if you export target documents, it seems)

2) Have to wait for preliminary matching to finish before CT works at speed again

Hi John,

1) Do you mean after export of SDL projects in SDL tool? If yes, perhaps it changes the status to translated after the export.

2) You don't need to wait for preliminary matching to complete. It just goes a few segments ahead of the current segment if you start it via Translate > Preliminary matching from current segment.

Hi Igor!

1) Yes, it seems to reset the status to translated once I have a) exported (all files or to package), then closed and reopened the project. This means that exporting the files before I am 100% finished resets the status and makes the "Checked" v "Translated" system above impossible.
2) Preliminary matching starts automatically for me each time I open a project. Have I missed a setting? It seems to run through thousands of segments, not just the next few segments, and takes a long time. How do you stop it?



1) Well, it seems to be a logical step to set to Translated at the export (I guess by export you mean finalize in CafeTran - not some export in SDL itself). Just do not finalize before reviewing the segments.

2) There is an option in Edit > Preferences > Memory tab > Switch to preliminary matching threshold. However, I wouldn't recommend raising it above the default number of segments because then CafeTran will switch to automatic matching without ahead progress, unless you start it manually anyway via Translate > Preliminary matching... command.

 It seems to run through thousands of segments, not just the next few segments,

I does keep running ahead but you can keep working at the same time. The matches should appear instantly without any delay.

Login to post a comment