Start a new topic

Auto-propagated match differs from TM match

This is what my TM shows:


image



And this is what CT propagates into the segment:


image

Why has the colon been deleted from the inserted match?


Settings:

  • Auto-propagation of everything except numbers (after this discussion)
  • numbers such as 4-33 and 4-47 are non-translatables (after the same discussion)
  • ‚Do not match‘ is completely empty (shouldn't it?)
  • TM and primary TB with high priority

Bonus questions:

1. If "4-47" is a non-translatable, shouldn't it be automatically inserted here, together with the match?

The matchboard shows the following:

image

2. Shouldn't the auto assembly windows show the best match + the non translatable as a, let's say, 80 % hit?

3. BTW, it does not recognize "Window" from the primary TB


I really suppose

  • this would not happen if there was a space instead of a tag between Window and 4-47 (or if CT would interprete the tag – a tab – as such)
  • this is the fault of any faulty setting, and that I am in need of Magic Hans and Magic Igor.


Indeed, the bold why question has most priority for me.


I think the above is not auto-propagation (from other project segments). The target segment is a TM 68% fuzzy match which the program auto-transfers into the target segment editor as the best available translation (better than 8% auto-assembling result). It removes the colon for you because there is no colon at the end of the number in the source segment either (the Transfer numbers to matches option is ON in Preferences > Auto-assembling tab).


Bonus questions:


CT does not append missing numbers to fuzzy-matches, it only corrects the existing ones.  

Unfourtunately Freshdesk did not accept my frist reply, so I'll anser once again.

Hm. The example above is taken from the Filter "Repeated and propagated segments". The number in the auto assemby pane is removed, okay, but then why is it removed on the way between TM view and auto propagation (NB: auto-propagation of numbers is off and this numerb is a NT).

 > CT does not append missing numbers to fuzzy-matches, it only corrects the existing ones. 


Even if these numbers are non-translatables?

I am a bit confused about your images as they clearly show 68% fuzzy match which may have nothing to do with auto-propagation. There exist a few distinct sources of auto-translation in CafeTran:


1. Auto-propagation

2. Exact matches

3. Fuzzy matches (with optional auto-correction and numbers replacement)

4. Auto-assembling

5. Machine translation (MT) services.


Apart from external MT services where the control on the translation quality is out of reach for the program, CT picks the result which is the most accurate and inserts it into the target segment editor if it is good enough. As you accept (and possibly correct) the auto-translation, it is auto-propagated to another identical segments in the project, or the ones which differ only in numbers or non-translatable fragments. There are various options to control auto-propagation (the "auto-propagation forward only" being the latest addition). Also note that if you change the "Do not match" field to ignore certain characters during matching, you need to restart the program or reload the translation memories.

In this cas I'd pick „3. Fuzzy matches (with optional auto-correction and numbers replacement)“ inseid the not enumerated, but in this list irrelevant Filter „Repeated and propagated segments“.

The fuzzy match is shown rather correctly in the TM view pane, but the colon has been eliminated although the relevant options (that would make this) are not checked. Indeed, there might be also the problem that this colon is only in the target text, not in the source text. As there are hundereds of these segments, I will imagine a solution routine for this, no problem, but it makes me wonder.

 

Login to post a comment