Start a new topic

Segmentation

Hi! I'm trying to import a memoQ segmentation file (.srx) but I think the format or something must be different as it doesn't work, actually I can pick the file from the segmentation menu but they're not applied.


The thing is that I'm mostly happy with the defaults BUT I really need segment at every comma, colon, semicolon... I tried a method (adding a rule) but I get the breaks where I want but always with an extra space at the beginning of the next segment, which slows me down... 


Does anybody know how to proper add the rule I need?


Thanks in advance!


Perhaps you set a rule to segment at comma, colon, semicolon, whereas it should segment at comma plus space, colon plus space, semicolon plus space? If so, you could try to add \s (or space) to the rule.

Thanks! This is my rule: [\.\?!;,]+ where should I add the \s?


Add space regular expression to your rule:


[\.\?!;,]+\s+

Kind of weird that . an ? require escaping and ! ; and , don't. But there's a valid reason for that. Just that I don't know it.

Great! It worked! Thanks a lot!

Yeah, why don't ; and , require escaping?

Because , and ? have a function in a regular expression, the others don't.


H

Indeed, I should have thought of that.

Login to post a comment