CafeTran Espresso 2017 - Yeddi Update 3

Hello everyone,


CafeTran Espresso 2017 Yeddi update 3 is available for download. The update can be performed via the Drag & Drop procedure as follows:

1. Run CafeTran.

2. Download file from here (do not unzip or rename the file after downloading) and place it on your desktop.

Note: On Mac OSX, the Safari web browser may unzip the file automatically after downloading. To prevent this, just use the right-click menu and choose the "Download Linked File" command.


3. Drag and drop the downloaded file into the Project Dashboard and restart the program.

Alternatively, you can install the update via the Update button in the Help > About panel instead of dragging and dropping.

What's new:

  • Improved mixing of custom formatting with transferred formatting. 
  • Fixed calculation of the translation speed per minute in the statistics. 
  • Added "Session duration" to the statistics. 
  • Blocked auto-propagation of source segments with numbers when there is no number in the corresponding target segment. 
  • Added "Show term information" right-click option to the display of and search results. 
  • Added the horizontal/vertical docking tabs option to enhance the personal adjustment of the user interface. It is available in the menu after right-clicking at the tab title. You will need to undock the currently-docked tabs before applying this new option.

Enjoy your weekend,


2 people like this

> The others have to be checked individually each time I open the project to work on it.

It's just been fixed (for this update as well). Please apply the same update 3 again.

3 people like this

>Now I have to tick the boxes each time I open a project.

Same here, twice this morning.

If you open an existing CT project, all TMs should open because they're included in the xlf file.



Maybe they should, they just don't seem to know it. The only TM that opens and remains checked is Total Recall. The others have to be checked individually each time I open the project to work on it.

Great, it's working again :-)

Thanks for the quick reply.

In that scenario - how is one to adjust alignments that are off on one side, and not on the other?

Say for example when importing, the Japanese segment was originally segmented into one sentence - but the English one was segmented into two sentences. After splitting the Japanese one to make two sentences and copying the text from the area below, to the blank space above it (that the English one has due to the Japanese being split) I'm constantly left with a blank space that I have to then copy up for each space thereafter... which, if I were able to merge just the English column up would streamline the entire process and make it a whole lot easier. 

Any suggestions to go about this? (Since we're going off topic, I could always make a new thread - let me know.)

Thanks for the screenshots. They show you have selected the automatic alignment method (no split documents tab visible). In the automatic alignment, CafeTran assumes that two documents have the same structure,that is, each source segment corresponds to the target segment. With this automatic method, joining and splitting functions affect both source and target simultaneously However, if you choose the default manual alignment, you can control the process (align the segments) ''as you go'' - navigating forward, joining and splitting either source or target or both, thus streamlining the process much more comfortably. Please choose the manual alignment and you should be able to achieve what you wish.

I'm also having the navigation arrow problem that Julie has described above. Hope it will be fixed soon (or has it already been fixed?).


I've just applied Update 3 again. The problem has already been fixed.

Thanks a lot, Igor!


Hi Igor, sorry to revive an old topic - but I really don't think the joining/splitting portion of aligning documents works as well as it should.  Like for example, I'm going through this document - and one sentence is like this: 


However, in English - since I don't use the ♪ mark it just ends up being this: 

My family is a Japanese candy maker.

So I need to split the Japanese - which I do. - Then, ideally, I click on join target segments - in which it moves the English up into the blank space, but it doesn't. 

What am I doing wrong? What can be done to make this a tad bit smoother/easier process? ._. 

If I understand the desired result well:

1. Place the cursor at the splitting point in the source segment.

2. Place the cursor at the start of the target segment (marking the split position in the target segment).

3. Just split.

You should end up as you wish (no joining is necessary).

BTW, you might update CafeTran. Your screenshot shows the (up-down) division of the source and target documents in the tab. The new version divides the documents view left-right. 

Hi Igor, the way you write makes it seem like I can have two cursors placed at two different points?

What I'll do is make a video of how I'm working and you can see where I'm having issues :).

As for the version, I'm using the latest one (updated before doing the screenshot) - perhaps it's not showing correctly for some reason...?


I noticed that recently the ability to remove a working language from the dashboard that was introduced with "CafeTran Espresso 2016 Ichiro - Update 18" after this post:

How to remove working language from Dashboard drop-down list

is not there anymore.

By the way, I would also be interested in the same solution to be applied to project names in the drop down list, so that one can clean up the list from unnecessary items. 

After applying this update, I think the Vertical tabs divider and Vertical docking divider have been set on by default, which may not be a good default when working with the "vertical" Window layout 2. 

is not there anymore.

It is still there as before after the right-click at the language bar. Nothing has been changed.

I think the Vertical tabs divider and Vertical docking divider have been set on by default, which may not be a good default when working with the "vertical" Window layout 2. 

They switch to the horizontal option when the Window layout 2 is selected. 

Login to post a comment