Start a new topic
Solved

Glossary not recognized on Linux

After switching my secondary installation to Ubuntu I have the problem that the glossaries (saved in the cloud) are not being recognized. The same glossaries were shared before between Mac OS X and Windows, the encoding is UTF-8 and the entries separator (shouldn't that be "carriage return type"?) is Mac OS X/Unix. A tab will be opened for the glossary, but there is no right-click possible.


This happens with any glossary.


Anyone can reproduce this?


You can attach a sample glossary to the support ticket.

Yeah, I got it.

I had installed CafeTran under the /opt/ folder. Most things ran fine, but obviously the CafeTran folder needs to be writable for the user. This behaviour is not to be expected, compared to other Linux programs.

Making the /opt/cafetran folder writable and executable for the user did not do the trick (but maybe I did the chmod command not right).

At least the sentence "Unzip the downloaded cafetran.zip file in the chosen location in your Linux system." in the tutorial should be modified. Many (of the very few) Linux users won't be happy to install software into their home directory.

 

Hello Tre!


Happy to see another GNU/Linux user.


 I have CafeTran installed on my home directory, but installing in the /opt/ folder is certainly good practice.


It may be so that the default permissions for /opt/ folder define root as the owner.


You could try the following (-R means that the permissions will be changed for all included directories recursively. Replace user:user with the name of your user, example: idim:idim):

 

sudo chown -R user:user /opt/cafetran
sudo chmod 0755 /opt/cafetran

 

Any software in any OS should be installed outside the user's or home direftory, indeed.


The opt directory is owned by root. When I did my first Linux experiments about fifteen years ago (Mandrake), I used to install custom softweare under /usr/share, if I remember correctly. I suppose that there are some more settings or lists that might make problems (also the update features, if the folder is not writable for the user (but there is no issue under Mac).


I had tried the commands you mention above before, but they did not work.

Out of curiosity (or for future reference), how was the issue solved?

I moved the Cafetran directory to my home directory. Not my preferred solution, but it works (and this installation is just an interim solution).
Login to post a comment