Start a new topic

Text Shortcuts don't work anymore in the Yeddi version


I'm surprised to see the shortcuts not working anymore, I have saved them correclty and the otpions show 'shortcuts.txt' and this file is also in the ressource directory of CT. But if I enter a shortcut then the expression will not be inserted anymore, in the Harbinger version the expression got inserted after hitting a space, if I remember well. Do you have to hit a special key command to insert them?


(I didn't verify your findings.) I'd like to bring to your attention that it's often more productive to use a generic tool like AutoHotkey, MacroExpress, TextExpander or Typinator: these tools work in all apps and in all dialogues. They are case-sensitive and offer useful extra functionality, e.g. for dates. Note that you best start your shortcuts with a letter like x (a letter that you reserve to start shortcuts and that doesn't require a keyboard shift), in order to prevent interference with auto-completion. One tool for all CATs--cross-platform.

This one is well supported and very actively developed:

Hi Mike,

Nothing has been changed in the Yeddi version regarding the text shortcuts. Please check if the shortcuts.txt file has any contents. You might have overwritten it during the update accidentally. If the file has the contents, please submit a ticket attaching this file.

Hi folks,
there is 1 difference in this situation where it doesn't work compared to the Harbinger-version situation where it did work: In the Harbinger I was working on a imported docx file; here in Yeddi I am working on a SDLXLIFF file.
I will try to run very simple shortcuts with simple 'single word only' strings in the shortcuts.txt to see if CT will accept some and refuse others, but in the Harbinger I was successful with even expressions containing  parenthesis and brackets. I will try to find out what has changed in my options (if anything) and report.



I have done some testing and it comes out that some shortcuts are not accepted while others are.
'aa' 'bb' 'cc' are not accepted;
'xx' 'yy' 'zz' are accepted instead
That's strange. Why this restriction?



That is weird. I have just checked and aa, bb, cc, xx, yy and zz work as text shortcuts in the Yeddi version. Do you have them listed after choosing Resources > Text shortcuts > List text shortcuts?


One more note: new text shortcuts need to be saved explicitly after listing them. Otherwise, they will be active only for the current session.


I suspect my shortcuts didn't work anymore because I have edited the shortcut file directly, this was bad for some reason.
 If shortcuts don't work anymore, the remedy seems to be: delete the shortcut file manually (no need to quit CT) and define expressions again in CT. At the end of working session I save them, otherwise they get lost. I have done all this and now it's all working, also aa, bb, everything. CT will make suggestions for the shortcuts: If I select "this is a very long string", the shortcut window will suggest 'tiavls' as a shortcut (the beginning letters); I can successfully change them however.

A lot of noise just because I have edited a file which I shouldn't have...Sorry for that, also I will chose my post titles more carefully next time :=)



Just to complete my list of suggested text shortcut apps: MacroToolworks.

I was a big fan of this tool when I used Windows.

It not only allows you to define text shortcuts but a lot more. There's also a free version. You can build macros that can manipulate strings in dialogue boxes of CafeTran, like the New Term dialogue box or the Quick term editor, etc.

Just one example macro from the site:

<#>This example shows how to find an e-mail addresses in input text


<form_item>("f1","Input text with e-mail addresses:","EDIT_ML10","This is a text that contains e-mail addresses 

such as 

or or other....","vInputText",1)

<form_show>("f1","Insert text with e-mail addresses","",0,500,0,,,1,1)





   <msg>(-100,-100,"No more e-mail addresses found.","",1,0,0,0)



   <msg>(-100,-100,"E-mail found: %vM%

Position in text: %vI%

Length: %vS%","",1,0,0,0)




It's like Keyboard Maestro for the PC ;).

I'm very glad to see that the 'Text Shortcuts' in CT will also accept expressions surrounded by tags. This is very convenient, e.g. for MemoQ bilingual imports. Also special characters with bullets are supported. You can then define for example:


Works perfectly!


As for the tags surrounding terms or fragments, you may have also noticed that if you insert a fragment from the Matchboard, its surrounding tags get transferred automatically as well. So it might be a good idea to add those phrases either as a term or a fragment (without tags) to your resource. 

Login to post a comment