Start a new topic

Request: Fix memory options

I am having problems setting the read only option on memories.


When I open a memory (any way - via the starting 'open project' page, via the menu), I am sometimes asked to choose the memory options (including this option) and sometimes not seemingly at random.

When I am not (and for all I know when I am as well), the 'Options' and 'Read-only memory' menu items on the memory tab context menu is sometimes (again seemingly at random) greyed out. This means that not only am I not able to set or unset this mermoy as read only, I can't even determine whether or not it is set as such.

This needs to be fixed.

In the current case, this is a secondary, reference memory, which I originally set as read only and wish to ensure is still set as such.


Can this please be fixed.



amos: This means that not only am I not able to set or unset this mermoy as read only, I can't even determine whether or not it is set as such.


When it's Read/Only, there's nothing much you can change, because... it's Read/Only. And it shows in the TMX file:


<prop type="x-read_only">true</prop>


To make changes, close the tab, and re-open the memory. Since setting files to R/O can go wrong (or rather, since I can forget this easily), I "lock" certain files so I can't possibly add segments to them, not even if I forget to set them to L/O.


image



H.



Hi Hans,

thanks for the suggestion, but closing and reopening the memory was of course the first thing I tried - to no avail. I still have no way of amending the options.
By opening the TMX with a text editor, I can see that prop type="x-read_only" is set to true, which is good to know, but I should still be able to change these options.

Jeremy

Hi Jeremy,


As you reopen the TMX memory either via the Memory > Open memory... menu or the Dashboard > Memories panel, you should be able to change the settings in the options panel that pops up. There was an issue in one of the earlier updates (the options panel did not show automatically after you chose the TMX file in the file chooser).

Nope, as noted above that doesn't work.

 

Login to post a comment