CafeTran Espresso 2017 Harbinger - Release Candidate 3

Ho ho ho,

 

CafeTran Espresso 2017 Harbinger aka Release Candidate 3 is available for download. The update can be performed via the Drag & Drop procedure as follows:


1. Run CafeTran.

2. Download 20161222_update.zip file from here (do not unzip or rename the file after downloading) and place it on your desktop.


Note: On Mac OSX, the Safari web browser may unzip the file automatically after downloading. To prevent this, just use the right-click menu and choose the "Download Linked File" command.

 

3. Drag and drop the downloaded file into the Project Dashboard and restart the program.


Alternatively, you can install the update via the Update button in the Help > About panel instead of dragging and dropping.


What's new:

  • New Term/Fragment dialog got a button to add a new entry without closing the dialog. It enables translators to add multiple TM/glossary entries at a time.
  • The refreshed dark and white eye-friendly texture themes (menu View > Themes). Image background transparent dark/bright themes are there to reduce eye strain and allow brightness adjustment with the slider in the source segment toolbar.
  • Polished Nimbus look and feel becomes default on Windows and Linux systems. It does not replace your current look and feel. You will need to choose it in Preferences > Appearance tab if you wish to try it.
  • New option: View > Tabs > Bottom tabs placement.


Igor


1 person likes this

Hello Igor,


I preferred the "cafe" theming on the top of the dashboard, but this is a matter of personal aesthetics.


On a more objective note, would it be possible to improve the buttons display (Open Project & Start a new project) ? On my installation, they are transparent and inherit the dashbord background.


This also occurs when choosing to Add a new document.


See the attached screenshot


Thank you!

dashboard.png
(62.9 KB)

>I preferred the "cafe" theming on the top of the dashboard, but this is a matter of personal aesthetics.


Yes, I really liked it. Made CafeTran standing out.

Thanks for the polished Nimbus! Looks gorgeous.


And the tab-at-bottom option looks wonderful.

Thanks for the feedback! I have just uploaded another build with small visual Dashboard's corrections and sticky (kept across sessions) option for the bottom tabs placement. As for the Dashboard's coffeehouse theme, it's back until I take a photo of another coffeehouse.


Igor

I cannot find the search bar anywhere. It was always there before, and after the upgrade -- gone. Have looked in the menus without any luck.

?????

>New Term/Fragment dialog got a button to add a new entry without closing the dialog. 


Long awaited, highly appreciated.


For me it would be useful if clicking on New term wouldn't delete the content of the source and target box (even when adding them to the glossary): this would allow me to easily add similar entries (like plurals that cannot be entered via selection or dash variants):


image


Similar entry:


image


Hey Terry,


Nice to see that you're still giving CafeTran a try!


Please use this menu to toggle the QuickViewBar:


image



1 person likes this

Duh, Quick search bar

For me it would be useful if clicking on New term wouldn't delete the content of the source and target box (even when adding them to the glossary): this would allow me to easily add similar entries (like plurals that cannot be entered via selection or dash variants):

 

Yes, it will be possible soon via holding CTRL key.


1 person likes this
Um, it's really not "duh".
Thank you, Igor, for letting me know how to get it back, and no thanks to cafetran.training for an indication that I don't think I'd want to do any training with you, if that's the attitude you take with your trainees.  Unfortunately, with no manual available, one has to rely on what one knows about similar programs, programs in general, and experience. I spend my time running translation through the program, not exploring it "just because".
The EDIT menu is usually an action menu -- one expects the entries under it to DO things (cut/copy/paste/find), not to DISPLAY things that cause different actions (and actions that have nothing to do with editing). That is the case in virtually every other program written. I have no problem with anything being put anywhere, as long as users are told -- without having to watch hours of videos -- especally when things change when updates come out.
All the toolbars are toggled in another location. To change what's visible on the screen, or the controls that are available, the enormous majority of programs use either VIEW or PREFERENCES. Take a look at whatever browser you're using right now and you'll see what I am talking about.
Searching "Help" doesn't...who would know to look for the word "quick" instead of "search" (which I did)? If one wants to know how to search internet resources, you look for "search resources", "search internet", "internet resources", not "quick search".


 

Hi Terry,


Just a quick note about the Edit menu. The vast majority of programs (especially editors) keep all the search/find related actions under the EDIT menu - yes, even the display of the search toolbar. You are right it may have nothing to do with the edition but I believe it is there for historical reasons.


Igor

Dear Terry,


>Um, it's really not "duh".


You couldn't know this, but the 'duh' was a kind of mental note to myself, because after having posted my reply, I noticed that the bar isn't called QuickViewBar but Quick search bar.


So I'd say that my attitude towards trainees isn't involved here.


Anyway, I wish you a Merry Christmas!


Kind regards,


Hans Lenting


Okay, Hans, gotcha.
Chalk up another one for the shortcomings of text communication!
I admit I don't know the "proper" names for anythign in the program -- just "that thing that you click to search" that was always there before. LOL

Merry Christmas (or holiday of choice, we have to be very politically correct in the US these days...LOL)
Terry

 

For me it would be useful if clicking on New term wouldn't delete the content of the source and target box (even when adding them to the glossary):

>> Yes, it will be possible soon via holding CTRL key.


In connection with this, I'd like to request additional buttons on the New Term/Fragment panels. Holding CTRL key might be a good idea, but such a feature must be documented somewhere simply because no one would try it unless they know it's available.


So, "visible" buttons should be better; they can speak for themselves.


My proposal is to add the following buttons.


Add & Clone (to retain the current content to add a more or less similar term/fragment pair)

Add & Clear (to clear the current content to add a completely different term/fragment pair)

Add & Close (to add the current content and close the panel)


Cheers,

Login to post a comment