Start a new topic

Problem with "Remove target segments the same as source" and "Transfer non-translatable segments to target"

 Hi Igor,

neither of the above commands from the "Task" menu appear to work properly.


1. Remove target segments the same as source

I'm translating am sdlxliff file supplied by the customer. When I first opened it in CT I got the standard "This file needs to be prepared in SDL Studio" (approximately) message. So I did so (copied all source to target). I then re-opened the file in CT, used "Remove target segments the same as source" to clear it for translation. This apparently worked, so I started translating. When I opened the file again later many (but not all - perhaps half) of the previously cleared target segments were once again filled with the source segment text. I repeated this a number of times, assuming I'd made a mistake (see also the next issue), but this behaviour is consistent.


2. Transfer non-translatable segments to target

The text contains lots of segments of the form [some-words-here] which i do not need to translate. so I set up a regex:  \[.+\] in non-translatables.txt (via "Resources" -> "Non-translatable fragments" -> "Edit non-translatable fragements" which should (and acccording to http://regexr.com does) find these. But nothing happens when I use "Transfer non-translatable segments to target". Am I missing something here??


Cheers,

Jeremy



Hi Jeremy,


1. CafeTran does not remove SDL locked segments or segments containing internal locks as they are meant not to be changed.


2. When you create a regular expression as your non-translatable entry, please make sure it is preceded by the '|' pipe character. It lets CT distinguish it from the regular entry.


Igor   

Hi Igor,

thanks for the quick response.
On 1.:
I'm surprised that you suggest that this is the problem. I don't believe that these segments are locked. (How would I find out in CT?) I'm pretty certain the (very good and highly competent) customer would not have locked segments at random. In addition, I am able to edit these segments manually and the edits are retained when I close and reopen the file. (I just tested this.)
I originally copied the source to the target segments as this was the instruction given when I originally tried to open the file in CT. The first thing I did when I then re-opened the file in CT was to remove target segments the same as source.

On 2.
Thanks for that. It would be nice if this was documented. It still doesn't solve my problem, however - even with the pipe and the regex given above (which I tested at regexr.com), these numerous segments are not transferred.

Jeremy



 


1 person likes this

Jeremy: It would be nice if this was documented


And not only this.


It still doesn't solve my problem


I tried another approach (I don't like regexes in CT):


In the Menu, Edit | Preferences (Options?) | Memory | Do Not Match. I deleted the square brackets temporarily. And sure enough, anything between them wasn't recognised by AA, although "Shell" is in my termbase, and was recognised before I removed them brackets.


Screen%20Shot%202016-10-25%20at%2017.12.46.png


H.

Thanks Hans, that's an interesting suggestion. I just tried it and it doesn't solve my particular problem unfortunately (transferring non-translatables to the target). I have the impression that the problem is specifically with this command. Has anyone ever successfully used this command?

 

Jeremy: ...it doesn't solve my particular problem


Do you use insert AA?


H.

I'm not sure exactly what you mean by that, so here's a screenshot of my AA settings:

blob1477392346292.png


 

This is crazy. There should be a setting like Insert Source Term if no matches are found. Can't find it...


H.

And Igor, whilst I've (hopefully) got your attention, the "Transfer source to empty target during translation" option doesn't seem to work. I've got it unchecked, but the source is nonetheless being transferred to empty targets.

 

> so I set up a regex:  \[.+\] in non-translatables.txt (via "Resources" -> "Non-translatable fragments" -> "Edit non-translatable fragements" 


Your non-translatable regular expression in the form |\[.+\] works just fine.

Hi Igor,
not here it doesn't. Perhaps I've simply miunderstood what the "Transfer non-translatable segments to target" is supposed to do. I expect it to transfer all source segments containing only non-translatable text to the target segment. What is it meant to do??

 

In fact lots of options don't seem to work with this file - e.g. "Auto-propagation to other segments".
If this a special CT 'feature' for sdlxliff files??

 

 Perhaps I've simply miunderstood what the "Transfer non-translatable segments to target" is supposed to do


That command transfers the non-translatable segment when the whole segment is non-translatable - not the one which only contains the non-translatable phrase.


I thought you were going to transfer the non-translatables from the current source segment via F4 keyboard shortcut.

Hi Igor,
no, I'm trying to transfer (lots of) whole segments of the form [some-text-here] (see my original question).
That's what I would expect the "Transfer non-translatable segments to target" to do.
I'm still not clear whether this is indeed the expected behaviour (it's certainly not the actual behaviour here).

 

As a bit of a by the by, it would be nice if this also ignored tags and whitespace. Some (but not many) of these have invisible tags followed by whitespace at the end and of course it would be even better if these were ignored. Is there a CT regex extension for tags?

 > Is there a CT regex extension for tags?


No, there isn't. However, in this case the mentioned space might be missing in your regular expression?

Login to post a comment