Start a new topic

Q: Selected text in Resources

Hi,

I translate from Japanese to French, but quite often I have to search for Japanese technical terms in my Japanese-English resources... and then in English-French resources.

The problem is that, if I select an English term in the Japanese-English Resources results, the selected term is automatically pasted into my target segment. How can I change this behavior... to do not paste the selected term(s) into the target segment and...


  • to automatically paste it in the Look up field

or

  • to tell CT to let me use my keyboard as usual to copy-paste the term(s) wherever I want?



Hi Alain,


Hold a CTRL key while selecting a term in your resources.

IK: Hold a CTRL key while selecting a term in your resources.


Even before you mentioned that, I tried all dead keys. Except for the Control key (^ on a Mac), they all still copied the term. Holding the ^ key didn't, but it also didn't select anything.


I'm curious, because my situation is similar to Alain's: I translate from two languages, English and German. For English, I have a rather huge database for technical terms, for German I don't, but I do have a large DE>EN database. I solve the problem by using DocFetcher, but that's outside CT.


BTW, I also had a look at Alain's tag problem. It's horrible. I copied a suitable paragraph of a Wikipedia article (in English, opened it in Japanese), and not only were there words in English, but most of them showed additional formatting, like bold, and even a link. I doubt if there's a solution for it. I mean hiding tags helps, but hiding irrelevant tags only would help more.


H.

I missed the Mac context here. Holding the CTRL key pops up the context menu on Mac so this solution does not work. The Command key should be used on Mac for this function. Please expect it in the next update. 

IK: I missed the Mac context here.


Never miss the Mac context. It's everything. And more.


H.

Sorry to be so late...
I tried with Ctrl... and it works!
My MacBookPro is connected to an external monitor and I use a USB keyboard. This keyboard has a Windows layout (with the "Windows logo key") instead of the Mac Command key. That might be there reason with I can use the Ctrl key...?


The only problem is that CT selects itself the words automatically in the Resources (for Japanese, always two characters even with longer words). I have to use the shift and arrow keys combination to select more than two characters.

>The only problem is that CT selects itself the words automatically in the Resources (for Japanese, always two characters even with longer words). I have to use the shift and arrow keys combination to select more > than two characters.


You can deactivate the Automatic selection of whole words in Edit > Preferences > Workflow tab.



Hi Igor,
Are you sure? It's already deactivated in my Preferences...

 

I mean... deactivating the Automatic selection of whole words is without effect when we select with Ctrl. Here is an example:


CT always selects only 2 characters. It seems to consider that a word, in Japanese, is always composed of 2 characters, which is not the case.


Login to post a comment