Start a new topic

Problem with auto-assembling (or wong settings?)

So I'm translating a file, but auto-assembling is prioritising nonsense fragment matches from the TM over glossary entries, despite the glossary priority being set to 'high' and the 'High priority for glossaries' box being checked on the 'Auto-assembly' preferences panel.

What am I doing wrong or is this a bug?

(Note: I'm still on about Update 11, but there's been nothing on this in the release notes, so I assume that's not the issue.)


1 person likes this idea

Your last image shows the target segment which is not exactly the same as the 27% the assembled one. It may come from the autopropagation from another segment that has been assembled (and accepted) before. I will keep an eye on those percentage values and this thread.

For instance, now I get an automatic insertion with a 15% assembled match, although I defined the minimum auto-assembly insert threshold at 70%. In this case, even the automatic translation (MyMemory) was better (see pic).


Thanks

Please check if you have activated "Automatic insertion of matches" in Preferences > Auto-assembling tab. 

Hi Igor, I see you're not watching the World Cup :D


I want the "automatic insertion of matches". Right? It's a great tool. If only I could optimise it, because for the moment it's not respecting the priority lists I defined in Preferences. That's the problem.

Hello,


Auto-assembling preferences are explained here: https://github.com/idimitriadis0/TheCafeTranFiles/wiki/1-Preferences#auto-assembling


What Igor is saying, is that "Automatic insertion of matches" should be set to OFF, as it is by default.


If this option is ON, CafeTran systematically inserts the auto-assembling result to the target language box.


Note: Auto-assembling insert threshold (%) option, available in the Memory pane can be used to control the automatic insertion threshold for auto-assembling.


Also, I suggest you test having Auto-assembling insert threshold set to 90, instead of 70. You can still use the Auto-assembling suggestion via the Dashboard or via the F1 shortcut, then selecting the result to insert.



Got it. So maybe the feature name is not that intuitive, because I now still get match insertion even though "Automatic insertion of matches" is off, it just respects the % I set.


Another thing, is I now tried to activate option "Transfer source to empty target during translation" but nothing happens. What I am trying to optimise here, in general, is a way to totally prevent omission errors, either by using automatic insertion of fuzzy matches or copying source to target when fuzzy matches are too low.

Hello again Luisa,


The option "Transfer source to empty target during translation" should work if the target segment is empty, but it might be prevented by some other setting I can't think about.


Is it really useful or do you use this only as a workaround?


If the issues you describe occur in more than one projects, while the settings seem correct, I would consider Resetting all settings.


However, this can be a major endeavor (even if some settings are stored in the Project templates), and you would need to take some screenshots of the options you use, if you have customized them.


I only suggest it because clearly something is off, and I don't think this is due to some bug at this state.


Alternatively, you can run a separate CafeTran version to test this (and avoid unnecessarily resetting the preferences, if it does not help).


I understand you wish to optimise CafeTran to fit your needs and prevent any omissions, this might require some further preferences/options testing, exploration and customization.


I would be happy to help in that direction.


Jean

I'm a bit late to this thread, but it seems to me that the two settings "Automatic insertion of matches" (hereafter "AIOM") and "Auto-assembling insert threshold" (hereafter "AAIT") should be linked.



If I've understood the above discussion correctly, setting AIOM to 'ON' has exactly the same effect as reducing AAIT to 0% and silently overrides the actual AAIT setting.


Wouldn't it therefore be more intuitive if setting AIOM to 'ON' automatically changed the AAIT setting (or at least the displayed setting) to 0%, and amending the AAIT setting automatically turned AIOM off?

Hi Jean, I'm taking you up on that offer of assistance. I still can't work with the auto-assembling/fuzzy matches and I have read your manual + tinkered with each parameter to try to optimise my settings.


I attach an example. My fuzzy matches are not automatically inserted in target. In this example, I get a 53% fuzzy match and have defined "Fuzzy match insert threshold" to 50% (I have even tried lowering this value to 20% but it doesn't work anyway, not even if I activate "automatic insertion of matches"). Actually, "automatic insertion of matches" works not for Fuzzy matches but for Auto-assembly matches, overriding my settings for "Auto-assembling insert threshold" (it inserted auto-assembling segments of 20-30%, although I set the value to 90%).


I really would appreciate to hear your thoughts on this. Thanks


Hello Luisa,


 

In your screenshot, I can't see the auto-assembling result and target segment, but the target segment does not seem to be auto-propagated.


Does this happen in more than one projects?


Here's what I suggest you try now (in the following order):


- Are you sure you want to leave a fuzzy match threshold this low? Currently, "Fuzzy match threshold" is identical to the "Fuzzy match insert threshold". I'm not sure this is a good idea.. I'd suggest you increase the percentage for "Fuzzy match threshold", 70% or 80%.  

- Make sure Automatic insertion of matches is NOT enabled in Preferences > Auto-Assembling.

- Set the auto-assembling threshold to 100% for now in Preferences > TM.

- In your current project, check your glossaries and your TMs one by one (by right clicking). Try enabling in each of your resources the option "Keep out of auto-assembling".

- Test if the issue is still reproduced on some new empty, non auto-propagating target segments. Your non translated target segments are empty, right? They are not filled with source or something else.


- If you still reproduce the issue, try on a new project, with only the ProjectTM and ProjectTerms enabled, no other resources. What happens?


Jean

Login to post a comment