Start a new topic

Filters switching off

I use filters "Untranslated segments" and "Alphabetical order".

Every time I need to copy a term to look it up on Linguee or elsewhere, filters go off and I have to set them again. How can this be prevented?

Wolfgang


Hello,


When you press Enter or the binoculars icon, it uses the "default search settings", the ones that are in place when you call "Ctrl + F".


Using "Ctrl + F", you can change default search settings (or launch more advanced searches and S/R operations)


Check and adjust the settings (use Default scope > Resources in Ctrl +F) OR enter the term you want to look up, and use the shortcut or specific button to lauch a specific search.


For example, with Linguee window active, press Ctrl+Shift+F1 to search the resource or use the Button with "Re" writen on the right.

Also check that Edit>Clipboard sensitive is NOT ticked.

But my problem still persists, that is, when I have to look up a term in the customer's reference pdf and therefore copy (CTRL+C) the term in CT's source segment, all my filters are reset from "Untranslated segments" and "Sort alphabetically" to "All segments". Quite annoying to set them again every time I want to look up a term. I have to resort to writing the term directly into the pdf's search window.


Hum, if Edit>Cliboard sensitive is not ticked, then I do not have a clue...


Maybe someone else will chime in!

I have no clue either. But did you know that you can facilitate this searching tremendously?


When you install the scriptable Skim PDF reader (open source) and a small AppleScript that you can assign to a keyboard shortcut and activate copy source segment, all you have to do when you enter a new segment, is to press that keyboard shortcut: any found matching string will be highlighted in Skim. It's simple but really looks sophisticated :).


I'm happy to provide the script. That is, I take it that you're still working on Mac?


Regarding the assignment of a keyboard shortcut to the script, there are several options. Personally I use Keyboard Maestro, but there are free utils too.

Thanks for your reply. This Skim pdf reader (which I had on my Mac (yes, 27" 4K brand new!) for years)) sounds interesting. So I thankfully accept your offer for the script which I will try out asap. (Who's writing, BTW, Hans? I an see no signature nor name?)

Best Wolfgang

Hi Wolfgang,


Please check if you have the menu Edit > Preferences > Workflow tab > Clipboard sensitive target box ticked with the Look-up option on.


Igor

If you deactivate/untick the Edit > Preferences > Workflow tab > Clipboard sensitive target box, the clipboard contents will stop being sent for automatic look-up and thus it will stop resetting the filters.


Igor

Yes, Igor, that's the way I wanted it to work. I just understood it the other way round.

Login to post a comment