Start a new topic

Edit spell check dictionary

Hi,


I'm not able to edit the Hunspell dictionary. When I click on Edit User's Spelling Dictionary, I just get a blank window that I can type into, but there are no buttons to confirm entries or anything.


With the "Edit User's Spelling Dictionary" feature, you can edit the entries that you've added to the dictionary yourself, not the entries of the downloaded dictionary files. If you've never added any entries, the user dictionary file is empty.

HTH
Martin

 

Thanks, Martin. 


By "entries added to the dictionary yourself" do you mean the glossary? 

If you right-click on a target-segment word that is marked as misspelled (i.e. underlined in red), you see a list of suggestions from the Hunspell dictionary that you can replace the misspelled word with. At the bottom of that list, you can find the word as you've written it. If you click on that word, it will be added to the user's spelling dictionary. Those words are what I meant by "words you've added yourself".

 

Aha, I also just found the option of adding a term to the spellcheck dictionary when saving a glossary entry.


I will definitely use the method you just described as well, thanks so much!

>Aha, I also just found the option of adding a term to the spellcheck dictionary when saving // Where is this option?

I'm wondering where it is too.


@Alyssa: One little remark: Besides the right-clicking method I described above, there are also the items "Show alternative spelling" and "Replace with alternative spelling" in the "Edit" menu (which also have keyboard shortcuts).

@cafetran.training,


Sorry for the confusion. I realized after the fact that what I "discovered" was actually what Martin suggested...I just figured it out while highlighting the terms to add to the Glossary and thus thought that it was a different process. On another note: if you just right-click on a word with a red-line underneath (on a Mac), the spelling options do not show up in a drop-down list. The word has to be highlighted for this to work. That's why I had a difficult time finding this option.


Login to post a comment