Start a new topic

Total Recall databases disappeared


I tried to move my total recall databases to another file outside CafeTran. After some time having trouble to do that (not finding the right pace) I decided to use the initial path inside CafeTran...problem!

After trying to find the pathway without success (because I cannot access the file through CafeTran directly) I decided to click on "Reset" so that all parameters would be set as by default.

Now, no more total recall memories anywhere...Did I just erase them by clicking on reset? Any way to retrieve it?

Thank you!!

I can't even create new databases. When I click on "new memory table" nothing happens... How can I get back to my .db file?

DON'T PANIC! CT will create a new, empty database when you run it again.

Try to find the old one by searching for the extension "db", and put it back in the CT package, or point to it in the Preferences/Options.


Thanks for your advice.

I ran it again, clicking on "new memory recall" nothing again.

I tried to look for the old one, nothing is found, even searching ".db" file. When I get into the CafeTran file from the finder, I can see there is a SqliteMemoryBase.db, but inside CafeTran I cannot redirect it to the file inside CafeTran. 


Plus, I only have 2 databases as far as I can see: H2 and Hsqldb...the last one is not there any more. 

I think you are mixing up databases and tables. Restart CT, and go to /Applications/

There's where the database can be found, SQLiteMemoryBase.db

It will be empty, if you indeed "lost" it earlier. Pretty easy to check: 2.39 GB in my case

There's little you can do with it, our Benevolent Leader Igor created it, and you can add tables to it, and that's it.

Try again to find the your old database, by searching for SQLiteMemoryBase.db or

and put it back in the location mentioned above.


Hi Kevin,

In your screenshot, I can see you selected JDBC in the Database connection field. Can you select the original SQLite and restart CafeTran?


Thank you, actually the "old" one is not empty so it means (I guess) I didn't lost it.

My problem is now, how to access it from CafeTran? 

As you can see the "original" access has disappeared. And when trying to access the file through "driver file..." If I select CafeTran I can't "open" the contents, only the path to the app, not into it. I'm not sure to be very clear here...

This is what happens...

You seem to have changed the original database configuration file.

1. Put the attached SQLite.res file inside package under the directory Contents/Java/infos/databases/

2. Start CafeTran and select SQLite in the Database connection field (Edit > Preferences > General tab). Press OK and restart CafeTran.

Now, it should point back to the original database file.


(137 Bytes)

Thank you, it woooorkkkss!!!! :) I have found everything again, thanks!

I just one last question (the first reason why I touched to the databases): how can I export a Total recall memory into a .tmx file? (Is it even possible?)

Thank you very much Igor!

> I just one last question (the first reason why I touched to the databases): how can I export a Total recall memory into a .tmx file? (Is it even possible?)

1. Total Recall > Recall memory...

2. Uncheck Recall in context and Read only boxes. Press the OK button.

3. Select the recalled memory tab and Memory > Save memory as...


Merci :)

Login to post a comment