Start a new topic

Export impossible -- URGENT

Hello,


I am trying to export a big document from CT. The "export finished" dialog opens, but the exported file is not created.


I need ugent help,

Thx,

Nathalie


Hi Nathalie,


The RAM memory in your system may not be enough for this big document. Try to open this project for export without any translation memories or other resources and then export again. If that does not help, please submit a support ticket.


Igor

Hi Igor, 16Gb aren't enough memory?

I did as you said, no other file in the project, no TM. Still does not export.


nathalie@Nat-Bureau:~$ java -XX:+PrintFlagsFinal -version | grep HeapSize

    uintx ErgoHeapSizeLimit = 0 {product}

    uintx HeapSizePerGCThread = 87241520 {product}

    uintx InitialHeapSize := 262144000 {product}

    uintx LargePageHeapSizeThreshold = 134217728 {product}

    uintx MaxHeapSize := 4194304000 {product}

java version "1.8.0_45"

Java(TM) SE Runtime Environment (build 1.8.0_45-b14)

Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

nathalie@Nat-Bureau:~$ 



BTW, when I want to add mem to java in CT configuration, it defaults back to 4096.



16 GB should be more than enough. However, your Java settings can limit the RAM for CT. Is this Mac or Linux? How do you increase Java Memory?

This is Linux, Ubuntu 14.04.

I increase the memory through the Memory config pane in CT. When I try to increase it, let's say for instance to 8 Gb, and I click OK, then the next time I open the pane, it defaults back to 4 Gb.

Do you run CT from the command line, via the provided script or via clicking the Start.jar file? The last method is recommended however various Linux distros do not associate the .jar extension with Java.

Start.jar


What I don't understand is that I was able to translate this big file,

I exported it to bilingual so that the editor could review it, then I reimported it.

No problem whatsoever.

The source doc is in source folder in projects, what else.

Regarding the TM I tried again to increase it, without success.

If you can run it via Start.jar successfully, go to cafetran's installation directory and edit cafetran.conf file. There check the second parameter: -Xmx


Try increase it to -Xmx8192m


and run CafeTran again.


Did you do QA tags check for this document?

Igor, 

I changed the memory size in conf file, but CT still displays 4096 in the settings pane.

Then I also ran QA on tags, passed, and again export failed.

The pane saying export successful still displays, but doc is nowhere (cannot open it even from pane right button).

When you create a bilingual document for review, CT does not need to load the source file located in the project folder. It only needs it during Export to recreate the document structure. It may fail if you edited externally that source document located in the project folder during its translation.


The 4096 settings may come from an earlier version if you updated CT to Harbiner or the latest Ichiro version. Did you translate this project with one (recent) version?


There is a way to recover it.


First step:

Open this project and convert it to TMX memory via Project > Convert/Export  > To TMX memory... It will create an exact TM of this project (with the correct tags position)


Second step:

1. Create a new translation project with this source document.

2. Load the TMX memory created as above. Make sure that the Tags processing option is on as you load it.

3. Go to Translate > Insert all exact matches.

4. Do QA tags and empty segments check and Export.


Igor




YES!!!!


Yes, I did not run the QA and empty segments check yet (will do before final export) because I still have another big chapter to finish tonight. But at least I was able to test the export of this 100,000 w. file and yes your method worked fine. I was anxious about the tag placements but they look fine.

Thanks for your help and your concern, I appreciate...

Cool I could help!

CafeTran's main resource is always available in plain text: TMX. Place it in your Dropbox and you will always be able to save your work. Even when it rains meatballs.
Login to post a comment